[Resolved] How do I add an image to my header?

Home Forums Support How do I add an image to my header?

  • This topic has 27 replies, 3 voices, and was last updated 9 months ago by Leo.
Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • #1173049
    Leo
    Staff
    Customer Support

    Anyway, do I need to move my hooks and page headers to elements?

    It’s not required, but I’d recommend it:
    https://docs.generatepress.com/article/moving-hooks-page-headers-to-elements/

    The site logo option in the header element would only show if there is a site logo uploaded in site identity:
    https://docs.generatepress.com/article/adding-header-logo/

    Any reason why you are using the merged option currently? Doesn’t look like that’s what you want – at least if you are still trying to re-create this example:
    https://www.forksoverknives.com/

    #1176543
    stefanie

    Hi Leo, I have managed to do some of the stuff I wanted to, but I’m still having a problem getting my menus onto the green strip (sorry I don’t know the names for things), which is the strip below where they are now. And how do I get my logo up to the very top in the part where the menus currently reside? I find that I cannot even put my logo on my site at the moment as I just get it to where I want it to be. It also needs to look right on mobile.

    Thanks 🙂

    #1176788
    Leo
    Staff
    Customer Support

    but I’m still having a problem getting my menus onto the green strip

    What if you just change the navigation colors to green in Customizer > Colors > Primary Navigation?

    Then add a logo in Site Identity:
    https://docs.generatepress.com/article/adding-header-logo/

    Then set the navigation location to below header:
    https://docs.generatepress.com/article/navigation-location/

    #1176809
    stefanie

    Hi Leo,
    I think we are almost there, and what you told me to do has worked really well. I like the look of it, but just one small hiccup. When I try to go into Navigation Location and press ‘Below Header’ it will put my menus below the header in customizer, but not on my live website. Can you check it from your end please? Thanks so much!

    #1176860
    Leo
    Staff
    Customer Support

    When something works in customizer preview but not on live site, it’s usually a caching issue.

    Can you disable all caching plugins for now?

    I’m seeing WP Super minify plugin activated.

    #1179453
    stefanie

    Hi Leo, so I deactivated all my caching plugins and tried to make the changes of getting my menu below my logo not above, but it still didn’t work. However, when I spoke to my hosting provider they looked at my website and it was all fixed, so they said it’s just the caching issue is the reason I can’t see it. What do you think? Can you please look from your end to see if it’s all fixed? I think it’s strange that I can’t see it and it bothers me a bit. I have tried clearing my cache on both my mobile and laptop and it’s still not working from my end. Thanks 🙂

    #1179852
    Leo
    Staff
    Customer Support

    This is what I’m still seeing:
    https://www.screencast.com/t/9C3X3a6F2C

    Just to confirm, this setting is set to Below Header?
    https://docs.generatepress.com/article/navigation-location/

    If so can you disable all plugins except GP Premium first?

    Let me know 🙂

    #1180080
    stefanie

    Hi Leo,
    Ok, so I deactivated every single plugin I have except Generate Press but it’s still doing the same thing. Yes, the setting is set to below the header, it shows up as published how I want it in customizer, but not showing up on live site. It’s really weird! What else do you think the problem could be as it’s not the plugins? I would just leave things as they are but it just doesn’t quite look right to have my menu above my logo. If you can think of any other options for me just to have an alright looking website then please let me know. It’s only a simple site at the moment with basically just social media buttons (which I could take away if it makes things easier), a logo, an image and a menu. There must be some way I can get these into an order that looks ok? Any suggestions welcome!

    Sorry this is taking so long and I appreciate you helping me 🙂

    #1180170
    Leo
    Staff
    Customer Support

    I’m still seeing WP Super Minify plugin activated.

    Can you disable that as well?

    #1182747
    stefanie

    Hi Leo, yes, I have deactivated Super Minify Plugin but still I am having the same issue, I can’t seem to get my menu below my logo. It’s really strange. I also deactivated every single plugin and tried to move it a couple of days ago but still no joy. I have left plugin deactivated for now so you can see. I don’t now hat to do next. Do you have any other ideas?
    Thanks

    #1182851
    Leo
    Staff
    Customer Support

    Do you happen to have a navigation location set in that header element?
    https://docs.generatepress.com/article/header-element-overview/#navigation-location

    Let me know 🙂

    #1183348
    stefanie

    Ok Leo, we’ve got to the bottom of it. I had it set to above header in elements. I’ve now fixed the problem easily. So, basically elements over rides customizer I have just learnt 🙂

    Anyway, thanks for getting to the bottom of it, I shall leave you in peace now until next time LOL

    #1183787
    Leo
    Staff
    Customer Support
Viewing 13 posts - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.