[Resolved] Horizontal scroll on mobile

Home Forums Support Horizontal scroll on mobile

  • This topic has 15 replies, 4 voices, and was last updated 1 month ago by Leo.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #1421092
    Dan

    on the mobile version of the site there is an horizontal scroll which I can’t wrap my head around.
    Don’t understand where it’s coming from.
    Using Gutenberg and GP blocks.
    This is a temp url:
    http://dd0ab622208e.ngrok.io/

    Any ideas?

    Thanks!
    Dan

    #1421124
    Dan
    #1421165
    Leo
    Staff
    Customer Support

    Hi there,

    The URL isn’t working for me.

    Can you double check?

    #1421671
    Dan

    can you try this link:
    http://0230cbd7bef0.ngrok.io/

    Thanks

    #1421682
    Nadine

    Hi, I am having the same exact issue. Have checked all the site settings. On some pages, the mobile version has a horizontal scroll. The site is http://www.green-waves-coaching.de (it’s on the home and about me page. The others seem to be fine.)
    How can I fix that? I am using the GP premium with elementor.

    #1421703
    David
    Staff
    Customer Support

    Hi there,

    looking at the Home page you are using the Elementor Stretch section option to make the full width.
    Which is not a great option as it uses JS to recalculate the width of the element.

    I would suggest you remove the Stretch option.

    And enable the GP Page Builder container to Full Width for the pages you’re using a pagebuilder on:

    https://docs.generatepress.com/article/page-builder-container/

    #1421726
    Dan

    I’ll upload the site to the server so you can take a look.

    Dan

    #1421733
    Nadine

    Thanks for the fast reply! I don’t seem to have the option. I can only set the container width to a fixed no of pixel. In the menu there is just “container” but not “page builder container”. Do I have to enable any other settings in GP so I can get this setting option?

    #1421744
    David
    Staff
    Customer Support

    Thanks Dan – let us know where its available

    Nadine can you raise a new topic where we can address your issue directly.

    #1421758
    Nadine

    Ok, I found it on the specific site settings. I was looking at the general Customizer options. I changed the setting according your suggestion. The issue still exists.

    #1421770
    David
    Staff
    Customer Support

    Nadine, you need to edit each of your Elementor Sections and in the Section Settings disable Stretch Section

    #1421949
    Dan

    Hi David,
    I’ve uploaded the site:
    https://www.agrobee.co.il/

    On mobile (or using the chrome inspector) you can see there is a gap on the left hand side.
    I am not using any page builders, just GPP and GP blocks.

    Thanks
    Dan

    #1421969
    David
    Staff
    Customer Support

    On some of your Grid Columns you have 30px left padding. You can set this to 0 in the Settings for Mobile. Or instead of using padding on the inside of the Column i would suggest increasing the vertical column gap on the Grid parent.

    Let me know.

    #1421984
    Dan

    Thanks David, that solved it.
    I would think that the mobile grid would reset it’s columns padding to 0 to avoid these kind of issues.

    Appreciate your help.

    Dan

    #1422014
    Nadine

    Hi David,
    thank you, did so, but still… it seems only to be on pages which have a disable – show page image. that’s the only thing I could find that they have in common.
    Best regards
    Nadine

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.