[Resolved] Horizontal Centering of Logo while keeping background 'boxes' flush with top

Home Forums Support [Resolved] Horizontal Centering of Logo while keeping background 'boxes' flush with top

Home Forums Support Horizontal Centering of Logo while keeping background 'boxes' flush with top

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #630796
    Chris

    Hi, I couldn’t find what I’m looking for in the support. Though I’m not sure exactly how to reference the issue.

    I’m having two issues:

    1 – In the Primary Nav, the Items/Links with a dropdown have a little more hight (seem to go 1-3 px lower) than those without drop-downs.

    Related to this, or looking at it the other way, the links without the drop-down are a bit ‘shorter’. This means there’s a 1-3 px gap between the Primary nav and the image below it.

    I’d like to have all the nav items/links (backgrounds) the same hight. And, I’d like that to be flush with the image below.

    How can I fix this?

    2 – In order to get the Primary Nav flush with the browser, I removed the padding. When this is done, the Logo is also flush with the browser. I don’t want this.

    Is there a way to horizontally center the Logo? Or, do I need to guess how much white-space to add to the Logo Img and upload it that way?

    Thanks

    PS to Admins. I didn’t add my URL because it’s in Maintenance mode and can’t be seen anyway.

    Below is a couple screenshots of the header.

    Header Pics

    GP Premium 1.6.2
    #630892
    Leo
    Staff
    Customer Support

    Hi there,

    It’s difficult for us to provide the best suggestion when we can’t see the site live.

    Looking at the screenshots, I believe the link below provides a better method to achieve the layout you are going for:
    https://docs.generatepress.com/article/navigation-logo/#navigation-as-header

    Can you give it a shot?

    If this doesn’t help then any chance you can add the URL in and disable maintenance mode so we can see the site?

    #630929
    Chris

    That did it.

    Just had to move the nav out of the header and add the logo; plus a couple tweaks.

    Thanks!

    #630949
    Leo
    Staff
    Customer Support
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.