[Resolved] Home page blog post images not linking to the post

Home Forums Support Home page blog post images not linking to the post

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #134558
    James

    Hi Tom,

    Hope you’re well. I finally made the switch to GP and I gotta say, you are a master of this art. It has a slight learning curve (if you are used to PF) but on the whole its a beautiful framework.

    I am currently creating a site and have this issue. I am sure it is just something I am missing, but I can’t work it out.

    I have a post, where the content is just an image. Within the post, the image is linked to a random post. However, on the homepage and category pages the blog post image also links to a random post. Is there anyway I can make it link to the actual post?

    Thank you and keep up the great work 🙂

    James

    #134585
    Tom
    Lead Developer
    Lead Developer

    Hi James,

    Glad you’re enjoying GP 🙂

    So the image is within your content? I’m afraid the only way you can do this is if you show an excerpt on your blog page and set a featured image which will link to your post.

    Then when you enter the post, hide the featured image (using Disable Elements), and your other image will display linking to the random post.

    Let me know if that makes sense or not.

    #134601
    James

    Hi Tom,

    Ok, so set an excerpt on the post and set a featured image which does link to the post, however the blog page is still showing 2 images (as the only content is an image im assuming?). One is a link to the post the other is the random link. How can I choose to only show the one image that links to the post?

    The url is imagehumor.com

    Thanks

    #134619
    Tom
    Lead Developer
    Lead Developer

    Looks like your blog is still trying to show the full content.

    Go to “Customize > Blog > Blog Content” and set it to “Show excerpt”.

    #134634
    James

    Ahhh! Awesome. You sir, deliver every time! 5 stars is never enough! Thank you 🙂

    #134663
    Tom
    Lead Developer
    Lead Developer

    No problem – glad I could help! 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.