[Resolved] Help with The Menu

Home Forums Support [Resolved] Help with The Menu

Home Forums Support Help with The Menu

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #241414
    Dorian

    Hi Tom,

    I am using the Primary menu and I have some problems in both mobile and desktop versions.
    The mobile menu doesn’t expand when clicked. The desktop menu when set to click either arrow or menu item does not expand. It just follows the link.
    I can live with the hover version of the desktop, but the mobile one is more critical.
    I remember I had some trouble with expanding the mobile menu when I first installed the theme. At the time it was doing it once in awhile. Now it’s pretty consistent.
    I tried a few combinations, but nothing worked.
    I have now:

    • Navigation width: contained
    • Navigation position: below header
    • Alignment: left
    • Navig Dropdown: hover
    • Nav search enabled
    • Sticky navigation enabled
    • Sticky navigation effect none
    • Could you please give me some ideas on what to change?

      Thank you,

      Dorian

    I love coffee and blogging.

    #241461
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    It sounds like javascript is broken on your page.

    Can you try #1 on this page?: https://generatepress.com/knowledgebase/debugging/

    #241482
    Dorian

    Thanks Tom,

    I just realized it only happens on the home page. It works on all other content, (pages or posts).
    I started to disable plugins until I noticed that was consistently not working on home page while functioning on all other pages.

    You still want me to disable all plugins?

    I love coffee and blogging.

    #241489
    Dorian

    Add try-catch wrapping? in Autoptimize did the trick.
    I added to the exclusion list jquery.js anyway.
    That is with Hypercache off. With Hypercache on, only the homepage is affected. ๐Ÿ™
    I’ll see if I can get an answer on Satollo forum.

    Thank a bunch for the help!

    Dorian

    I love coffee and blogging.

    #241493
    Tom
    Lead Developer
    Lead Developer

    Those are PHP errors most likely related to a plugin you’re using.

    Looking at your site, it’s saying jQuery isn’t defined.

    In the Autoptimize settings, exclude jquery.js and see if that fixes it.

    #241810
    Dorian

    The page builder I was using, combined with Hypercache caused the issue.
    I converted the homepage, (the page that was broken), to a regular page, (some html cleanup), and puf, it worked.

    Planning to move away from my page builder to plane html.

    Thanks for the help Tom!

    You are awesome, and your theme rocks.

    Dorian

    I love coffee and blogging.

    #241816
    Tom
    Lead Developer
    Lead Developer
Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.