Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Support request] Headers acting funky

Home Forums Support Headers acting funky

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #408113
    Jason Westbrook

    Hi,
    I am experiencing header presets working on some pages and other pages it is not. Some pages show old way of headers to show up while others have the headers select at the bottom of the page since the newer version came out. I included the url for your review. I have a preset transparent header that isn’t working on the page provided. Any ideas?

    GeneratePress 1.4
    GP Premium 1.4.3
    #408145
    Leo
    Staff
    Customer Support

    Hi there,

    The site is under maintenance. Can you double check? Thanks!

    #408148
    Jason Westbrook

    My apologies. Please try again. 🙂

    #408192
    Leo
    Staff
    Customer Support

    Hmm you are not using the page header on that page?

    This page is using the page header and the merge option: http://builtonmission.com/our-work

    #408567
    Jason Westbrook

    True but the /get-started page has a header template drop down only from which I created 2 different header templates. But the page you referred to above is the old style where you could trigger per page the header options manually instead of the new global template settings. So when I choose transparent header type nothing happens. Weird.

    #408569
    Jason Westbrook

    There is some sort of conflict. Some pages show old way header options and some show new header template options. Both are present on the site depending on what page I am using.

    #408603
    Leo
    Staff
    Customer Support

    The existing page headers (except blog) were not migrated over to the new system so they will still show up in the metabox per page.

    If there wasn’t an existing page headers before then you would create it using the new system. All options in there should still be the same.

    The new way makes it easier to re-use the page headers but you can have the old metabox per page method back by using this snippet: https://docs.generatepress.com/article/generate_page_header_legacy_metabox/

    #408646
    Jason Westbrook

    Forgive me for being a pain. I have that snippets added and still cant get the page to do the transparent header. I must be missing something. Something is conflicting. It forces me to choose a preset header in combination with activating old way to make it work. But now the background of the primary navigation is showing white instead of transparent. Something is bugging out here. Are you able to login and check my settings?

    #408647
    Jason Westbrook
    #408737
    Leo
    Staff
    Customer Support

    Your site is no longer working for me. It says 403 error.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.