Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Resolved] Header with doubled (!!?) menus impossible to replace

Home Forums Support [Resolved] Header with doubled (!!?) menus impossible to replace

Home Forums Support Header with doubled (!!?) menus impossible to replace

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #466881
    Mikael

    I’ve a big problem when trying to replace the header, because the old one will not disappear. After created the new one in Elementor and put it in by GP hooks; the result is the new nice menu + the old one + an extra menu. Have created a nice footer in the same way and no problems (made it in AE templates to get the short code and then use GP hooks).

    I have tried to remove/delete the old one, I’ve tried simple css: # header { display: none } or just have tried different way to add on the new header ..and it works but the old menu or the full header is still there as a ghost and the the old menu is a real mess not as previously.
    I’m using generatepress premium/statement and elementor, AE templates, GP hooks
    Is there any way to remove or delete customize settings for my old header?

    #467000
    Leo
    Staff
    Customer Support

    Hi there,

    Can you try setting this to No Navigation? https://docs.generatepress.com/article/navigation-location/

    Not sure if it will hide both but worth a shot.

    If not can you link me to the page in question?

    You can edit the original post and use the private URL field.

    #467028
    Mikael

    OK, it didn’t solved the problem. I have still 2x menus.
    I have tried so many different settings in the customizer so you might be on right track..
    For example I have changed the settings: Customizer / Menus / Menu location .. Primary Menu was -select- but when I changed back to Primary Menu the mess was cleared up but still 2x menus.
    Yes please, to have a look at my site http://www.masterlienergy.com
    (I can give you access but not sure how to do..)
    My email: info@masterli.se
    Thanks Mikael

    #467056
    Leo
    Staff
    Customer Support

    What happens when you select No Navigation in navigation location?

    Nothing?

    #467073
    Mikael

    Ahhh fantastic, thanks very very much, now it works 🙂
    I just follow your link and there it was below header so didn’t put it in “no navigation”
    (it’s late hour here in Sweden and I’m a bit tired.. and have spent 30 hours at this problem)
    Thanks again!!!

    #467130
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.