[Resolved] Header Element

Home Forums Support [Resolved] Header Element

Home Forums Support Header Element

  • This topic has 17 replies, 2 voices, and was last updated 4 months ago by David.
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #2183227
    Rick

    I have installed the Artisan content from the Site Library and I’d like to replicate the “Home Page Header” element used in this package. However, when I try to create a new Header element, there is no content area (below the Element title) to enter HTML as done with the Home Page Header. How do I get a content area to show up so I can enter HTML?

    NOTE: I do not use any Block editors. The instructions on this page don’t seem to help:
    https://docs.generatepress.com/article/how-to-create-a-page-hero/

    Thanks!
    Rick

    #2183366
    David
    Staff
    Customer Support

    Hi there,

    When you edit or add a new header element it opens with the Site Header tab, click the Page Hero tab to see the text editor.

    #2183446
    Rick

    Thanks David, I appreciate your help. However, there is no text editor with either tab. What am I missing?

    No text editor

    #2183448
    David
    Staff
    Customer Support

    Can you check that image URL as its 404ing not found for me?

    #2183451
    Rick

    Sorry, I removed it by mistake. How’s this?

    No Text Editor

    #2183455
    David
    Staff
    Customer Support

    Well that is odd.
    Can you check for Plugin conflicts by temporarily disabling all but GP Premium

    #2183458
    Rick

    All plugins deactivated except for GP Premium. Same result:

    New Header

    #2183475
    Rick

    UPDATE: I built a new WordPress site, hoping to rebuild everything from the ground up to see where the failure is introduced. Everything worked perfectly until I installed the Duplicator PRO plugin. At the point, I had no text editor. After I removed Duplicator PRO altogether, I still had no text editor. I’ll repeat this exercise to double check the issue.

    #2183631
    David
    Staff
    Customer Support

    Hmm.. that is odd. I am gonna pass this topic onto Tom to see if he has any insights

    #2183649
    Rick

    Thanks David. I just tried another test by installing a clean copy of WP and only the GP Premium plugin. Again, no text editor with the Header Element. However, there is a text editor with the Hook Element.

    If you need an admin account to troubleshoot, I’m happy to provide one.

    -Rick

    #2183667
    David
    Staff
    Customer Support

    If you could provide us an admin account login ( in the Private Information field ) then we can take a closer look

    #2183694
    Rick

    This must be a problem on my end. When I created a new admin account and logged in, the text editor works fine. When I login with the original admin account, the text editor is still missing. Goofy, eh?

    If you want to close this ticket, that’s fine with me. If you want to pursue it further, I’m happy to participate.

    Thanks for your EXCELLENT support!

    -Rick

    #2184322
    David
    Staff
    Customer Support

    Hmmm… I wonder if the browser cookie/localStorage fro your login got messed up. What happens if you login on a different browser ?

    #2184347
    Rick

    I’ve tried the usual things, including different browsers, clearing the browser history, clearing the server cache, etc.

    Thanks again for your interest in this issue. I’m not going to take up more of your time, so I’ll close this ticket.

    Thanks David!

    #2184527
    Rick

    Hi David,

    Since I closed this ticket, I’m not sure if you’ll see this. I’m pretty sure I’ve stumbled onto the reason why the text editor is not showing with the Header Element. If you check the box for “Disable syntax highlighting…” in the User Profile, the text editor is not visible. Uncheck the box, and it comes back.

    Syntax highlighting

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.