[Support request] Header

Home Forums Support [Support request] Header

Home Forums Support Header

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #607211
    Mark

    Hi

    Please see my current project which is a combination of GP Pro and Elementor Pro. Thanks for the good work you guys are doing.

    I have got myself in a muddle with the top bar – to be clear on my part I mean everything from the menu upwards. In my case I have used Elementors header as you can probably tell.

    I am happy with the look but not the navigation and I would like to use your menu. Can you think of a way to keep the elementor part above the menu but use your mega menu? Or can I achieve the whole thing in GP which I would prefer.

    Thanks again and keep up the great work.

    Mark

    GeneratePress 2.1.2
    #607474
    Leo
    Staff
    Customer Support

    Hi there,

    For the header you can do something like this:
    https://docs.generatepress.com/article/split-header-three-sections/

    Just need to split into 4 parts:
    https://docs.generatepress.com/article/creating-columns/

    Something like 40-20-20-20 should work for you.

    Let me know 🙂

    #607865
    Mark

    Thanks Leo – I didn’t manage to get this to work but you put me on the right track and I ended up putting a shortcode in the hook which did the job.

    Good news is that I get your menu back, the bad is that I have some unwanted padding and cant make it full width? Any ideas?

    Thanks

    Mark

    #607903
    David
    Staff
    Customer Support

    Hi Mark,

    ok, first off in the Customiser > Layout > Header – set the padding to zero.
    Then Layout > Primary Navigation > Navigation Width > Full
    Lastly the Top Margin is coming from this CSS:

    /* Push nav down on desktop */
    @media (min-width: 769px) { 
        .main-navigation { margin-top: 30px; }
    }
    #607914
    Mark

    David – you legend.

    Clearly I have not helped myself with the css.

    My final issue is that my menu is still contained despite following your instructions and left aligned?

    Any ideas?

    Thanks in advance

    Mark

    #607916
    Mark

    All sorted David, thank you.

    #607920
    David
    Staff
    Customer Support

    Glad we could be of help Mark

    #607923
    Mark

    Amazing support, thank you.

    Do you notice a strange glitch in the pageload in the header in Chrome?

    #607927
    David
    Staff
    Customer Support

    Hi Mark, yes some FOUC, because Elementor loads its CSS in the footer for these templates. So they don’t render until the content is loaded. Elementor provides this solution:

    https://docs.elementor.com/article/249-embedded-template-css-loading

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.