[Support request] Having trouble starting again….

Home Forums Support [Support request] Having trouble starting again….

Home Forums Support Having trouble starting again….

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #468804
    William

    Hello!

    I purchased GeneratePress back in December 2016 for $39.95 and did some testing on a few of my own websites for a project that fell through, however I’ve only just come to start a serious family business project (I have no activated websites at the current time)

    It seems my licence key has expired and it’s preventing me from downloading the latest GP Premium Plugin (gp-premium-1.5.6.zip). I used the one I had in my downloads folder from July (gp-premium-1.3.zip) but it won’t activate on my new website with my licence key.

    1) Am I not allowed to download GP Premium v1.53? Not a real problem as I have GP Premium v1.3 so I can just use that. I guess I havent paid for access to this version?

    2) My licence key won’t activate with my v1.3 plugin. Am I not allowed to activate my licence key anymore? I thought my licence was lifetime usage on my own websites? The website says “lifetime usage” so I thought this was a formality?

    Sorry if I wasn’t 100% clear, I’ve read all the documentation but I couldn’t find a definitive answer!

    Regards,
    William.

    GP Premium 1.5.6
    #468922
    Tom
    Lead Developer
    Lead Developer

    Hi William,

    Typically it’s assumed that GPP has been downloaded already. Feel free to contact us using the Account Issue form and we’ll get you that version: https://generatepress.com/contact/

    You can use the plugin forever at whatever version you were on, but you need an active license key to get the latest updates. We used to have lifetime licenses, however some people actually chose not to go with GP because if it. Yearly renewals ensure the longevity and health of the business.

    Let me know if you have any other questions 🙂

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.