[Resolved] Hamburger menu content opens up at the bottom of the page (unwanted)

Home Forums Support [Resolved] Hamburger menu content opens up at the bottom of the page (unwanted)

Home Forums Support Hamburger menu content opens up at the bottom of the page (unwanted)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2061240
    Hugo

    Hi,

    I just noticed some weird behavior, without me doing this as far as I know. I just noticed it, so it might have been this way for a couple of days already…

    I have a hamburger menu and when I click on it from a logged-out browser in incognito, the screen scrolls to the far bottom of the page (below the footer), where the menu shows up. This is not supposed to happen. Previously, it was supposed to slide out from the right (which it’s still supposed to do, as the settings in my “Customize” menu are correct. I checked this guide to make sure that it’s not the settings that are causing this: https://docs.generatepress.com/article/off-canvas-panel-overview/

    On both mobile and desktop, the slideout doesn’t happen, and the view is awkwardly scrolled to the bottom where the menu suddenly appears.

    What could be the cause of this?

    #2061335
    Elvin
    Staff
    Customer Support

    Hi there,

    The script for the off-canvas panel isn’t running properly. This usually occurs when an optimization plugin is messing w/ the scripts of the page.

    Can you try disabling ALL plugins except GP Premium and see if it works? You then enable plugins one by one to see which one is causing the issue. (usually it’s the optimization plugins like WP Rocket).

    A wise man once said:
    "Have you cleared your cache?"

    #2061540
    Hugo

    Thank you!

    Apparently, WP Rocket’s “Remove Unused CSS” messed it up. I turned off this option, and now the usability is restored.

    Thanks for your quick reply!

    #2062272
    Elvin
    Staff
    Customer Support

    No problem. Glad you got it sorted. 😀

    A wise man once said:
    "Have you cleared your cache?"

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.