[Support request] Gutenberg plugin not working with GP Premium

Home Forums Support Gutenberg plugin not working with GP Premium

  • This topic has 11 replies, 7 voices, and was last updated 3 months ago by Leo.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #536361
    Reuben

    Hi there,

    I noticed with the latest version of the GP Premium plugin installed, I can no longer use the new Gutenberg text editor. Whenever I create a new post, it automatically redirects me to the Classic Editor instead.

    This strangely only happens when GP Premium plugin is enabled. It did not do this previously. May I know what is wrong? Thanks!

    GP Premium 1.6.2
    #536470
    David

    In the changelog for 1.6 I see that it will disable Gutenberg if Sections are used.

    I’m pretty sure that’s what you’re seeing. I remember a discussion here where Tom said that those weren’t compatible due to significant editor changes in Gutenberg. That’s one reason I’ve held off on using Gutenberg, except for testing environments.

    Dave

    #536763
    Tom
    Lead Developer
    Lead Developer

    Yes, this will only happen if you have the Sections module enabled.

    Since Sections isn’t currently compatible with Gutenberg, it disables it.

    Once Gutenberg fixes an open issue they have with the TinyMCE error, we’ll be able to run both together 🙂

    #539415
    neverything

    @Tom: What are your plans for making sections compatible with Gutenberg? I might be able to help out building the blocks for it on company time.

    Do you plan to move them to Gutenberg at all? Would a simple block that renders them including the settings be an option or would you rather move them to columns with nested blocks instead, since most features like section background color can be done in Gutenberg as well?

    I’m open for dicussion, let me know if you can share your plans already.

    #539905
    Tom
    Lead Developer
    Lead Developer

    I’m kind of just waiting. There’s discussion happening within Gutenberg about creating a “Section” block.

    If they do that, we’ll wait until it’s possible to extend existing blocks, and will add our current Sections options to the existing Section block.

    If they don’t, we’ll likely build our own Sections block, however I’m not a big fan of that, as you’d likely lose your content if you switched themes.

    #540588
    neverything

    Thanks for your reply Tom!

    If they do that, we’ll wait until it’s possible to extend existing blocks, and will add our current Sections options to the existing Section block.

    Yes I see, that makes more sense.

    If they don’t, we’ll likely build our own Sections block, however I’m not a big fan of that, as you’d likely lose your content if you switched themes.

    Ohh absolutely that wouldn’t be very good, would an additional add-on just for the sections possibliy make sense?

    #541117
    Tom
    Lead Developer
    Lead Developer

    I think that would be the best method if it comes to it. Hopefully they add a core Section block which we can extend 🙂

    #541645
    neverything

    Fingers crossed 🤞 this will be the way they do it.

    #554060
    Ivan

    Maybe i miss something, Where i can test Gutenberg’? I don’t see it in my WP Installations

    #554195
    Tom
    Lead Developer
    Lead Developer

    It’s currently a plugin. If you go to “Plugins > Add New” and search for “Gutenberg”, you’ll see it 🙂

    #1183397
    Greg

    Hello… I have a similar issue.
    When I create a posts page, everything seems to be ok as far as the editor goes. When I leave the editor for that page and go back, I get a page with ‘custom fields, comments, discussion, etc’ and NOT a classic or gutenberg editor. I do not have sections enabled. At first I thought it was related to trying to add a custom header to the posts page but now it happens even after I add the posts page to the main menu. Any help would be greatly appreciated…

    ps. right now the site is only in development so I do not have a url to send a screenshot, etc.

    Thanks

    #1184121
    Leo
    Staff
    Customer Support

    Any chance you can open a new topic?

    Thanks 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.