Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Resolved] GP Pro update and Elementor

Home Forums Support [Resolved] GP Pro update and Elementor

Home Forums Support GP Pro update and Elementor

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #531971
    Julia

    Hey guys! So both updates of GP and elementor rolled out at the same time.

    Now the issue is, I can’t save my page, it shows a Server Error (400 HTTP/2.0 400) error.

    I’ve put the memory limit to 1g, tried it, then put it back to 64mb, then bumped it up again. I’m not sure what’s causing the error.

    I’ve already flushed all caches, tried with all plugins deactivated. Not sure what else to do.

    Rolling back the plugin to 1.9.8 didn’t solve the issues. I’m not sure where the problem is so I’m posting it everywhere.

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: 5.6.23
    PHP Version: 7.2.3
    PHP Max Input Vars: 10000
    PHP Max Post Size: 1G
    GD Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 4.9.4
    Site URL: https://thebrandingirl.com
    Home URL: https://thebrandingirl.com
    WP Multisite: No
    Max Upload Size: 1 GB
    Memory limit: 768M
    Permalink Structure: /%postname%/
    Language: en-US
    Timezone: 0
    Debug Mode: Inactive

    == Theme ==
    Name: GeneratePress
    Version: 2.0.2
    Author: Tom Usborne
    Child Theme: No

    == User ==
    Role: administrator
    WP Profile lang: en_US
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6

    == Active Plugins ==
    A2 Fixed W3 Total Cache
    Version: 0.9.4.6.4.4
    Author:

    A2 Optimized WP
    Version: 2.0.10.7.1
    Author: A2 Hosting

    Add From Server
    Version: 3.3.3
    Author: Dion Hulse

    All In One Schema Rich Snippets
    Version: 1.5.2
    Author: Brainstorm Force

    All In One SEO Pack
    Version: 2.4.6.1
    Author: Michael Torbert

    Custom Post Type UI
    Version: 1.5.7
    Author: WebDevStudios

    Duplicate Post
    Version: 3.2.1
    Author: Enrico Battocchi

    Elementor
    Version: 2.0.0
    Author: Elementor.com

    Elementor Pro
    Version: 1.5.4
    Author: Elementor.com

    EWWW Image Optimizer
    Version: 4.1.1
    Author: Shane Bishop

    Facebook for WooCommerce
    Version: 1.8.2
    Author: Facebook

    Force Regenerate Thumbnails
    Version: 2.0.6
    Author: Pedro Elsner

    GP Premium
    Version: 1.6
    Author: Tom Usborne

    Instant Images
    Version: 3.1
    Author: Darren Cooney

    Jet Elements For Elementor
    Version: 1.8.1
    Author: Zemez

    JS & CSS Script Optimizer
    Version: 0.3.3
    Author: Yevhen Kotelnytskyi

    Newsletter
    Version: 5.3.2
    Author: Stefano Lissa & The Newsletter Team

    Newsletter – Automated Newsletters
    Version: 4.2.2
    Author: The Newsletter Team

    Newsletter – Contact Form 7
    Version: 4.0.9
    Author: The Newsletter Team

    Newsletter – Extended Composer Blocks
    Version: 1.0.0
    Author: The Newsletter Team

    Newsletter – WooCommerce
    Version: 1.2.6
    Author: The Newsletter Team

    Printify shipping for WooCommerce
    Version: 1.0
    Author: Printify

    Remove Query Strings From Static Resources
    Version: 1.4
    Author: Speed Up My Website

    Rename wp-login.php
    Version: 2.5.5
    Author: Ella Iseulde Van Dorpe

    SVG Support
    Version: 2.3.11
    Author: Benbodhi

    TinyMCE Advanced
    Version: 4.6.7
    Author: Andrew Ozz

    Virtual Robots.txt
    Version: 1.9
    Author: Marios Alexandrou

    WC Speed Drain Repair
    Version: 1.2
    Author: WP Fix It

    WooCommerce
    Version: 3.3.4
    Author: Automattic

    WooCommerce PayPal Express Checkout Gateway
    Version: 1.5.2
    Author: WooCommerce

    WooCommerce Stripe Gateway
    Version: 4.0.7
    Author: WooCommerce

    WP Disable
    Version: 1.5.15
    Author: optimisation.io, hosting.io

    == Debug ==
    Errors:
    TypeError: undefined is not an object (evaluating ‘t.element’)
    at https://thebrandingirl.com/wp-content/plugins/elementor/assets/js/editor.min.js – 2:138090
    2018-03-26 17:21 +00:00
    x 34 times

    TypeError: undefined is not an object (evaluating ‘elementor.config.user.is_administrator’)
    at https://thebrandingirl.com/wp-content/plugins/elementor/assets/js/editor.min.js – 2:154143
    2018-03-26 12:29 +00:00
    x 15 times

    TypeError: undefined is not an object (evaluating ‘c.nodeType’)
    at https://thebrandingirl.com/wp-admin/load-scripts.php?c=0&load%5B%5D=mce-view,imgareaselect,image-edit,quicktags,wplink,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomplete,thickbox,media-uploa&load%5B%5D=d,heartbeat,wp-auth-check,jquery-ui-resizable,imagesloaded,jquery-ui-draggable,jquery-ui-slider,jquery-touch-punch,iris,wp-color&load%5B%5D=-picker&ver=4.9.4 – 16:307
    2018-03-19 06:06 +00:00

    TypeError: undefined is not an object (evaluating ‘t.element’)
    at https://thebrandingirl.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.9.8 – 2:120269
    2018-03-16 11:01 +00:00
    x 32 times

    TypeError: undefined is not an object (evaluating ‘j.style’)
    at https://thebrandingirl.com/wp-admin/js/editor.min.js?ver=4.9.4 – 1:693
    2018-03-13 12:03 +00:00
    x 2 times

    TypeError: elementor.getPanelView().getCurrentPageView().showView is not a function. (In ‘elementor.getPanelView().getCurrentPageView().showView(“search”)’, ‘elementor.getPanelView().getCurrentPageView().showView’ is undefined)
    at https://thebrandingirl.com/wp-content/plugins/elementor-pro/assets/js/editor.min.js?ver=1.15.1 – 2:30305
    2018-03-13 07:25 +00:00

    GeneratePress 2.0.2
    GP Premium 1.6
    #531985
    Julia

    I just switched to OceanWP to test, and then it saved ok. Seems to be with GP.

    #531988
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    There shouldn’t be anything within GP causing this. The 1.6 update wasn’t a big one aside from the new Site Library, whereas the Elementor update is a huge one.

    If you switch back to GP, does the issue come back?

    Is there a more specific error in your error_log file?

    #531996
    Julia

    Switching back to GP does bring the error back. Where can I find that fie?

    #531997
    Tom
    Lead Developer
    Lead Developer

    It should be in your root directory, along with the wp-admin, wp-includes and wp-content folders.

    If you can’t find it, you can ask your hosting to investigate the error to see if they can see the cause.

    #532001
    Julia

    I’ve already submitted a ticket regarding this, as you can imagine they told me to deal with you X) I don’t have the time to fully reconfigure the website with another theme, what else can I do?

    #532003
    Tom
    Lead Developer
    Lead Developer

    We need more details on the error. Server error 400 is very broad.

    There should be more details on the error in your error_log file.

    Have you tried disabling your other plugins to rule out a conflict with one of them? I see a lot of people having issues in the Elementor Community with the 2.0 release and plugins like Jet Elements.

    #532004
    Julia

    And I don’t have the error log file.

    Rolling back the theme to 2.0.1 solved it. It does seem to be on GP’s 2.0.2 end ๐Ÿ™

    #532008
    Tom
    Lead Developer
    Lead Developer

    GP 2.0.2 has been out since January 16, so I don’t think that’s the issue.

    There’s also very little difference between 2.0.1 and 2.0.2, it was a minor update with a couple fixes.

    It’s possible that there’s some sort of caching issue going on. What happens if you go back to 2.0.2, and then clear all caches?

    #532009
    Julia

    I did get an update yesterday which started the issues. I will make my edits and try that!

    #532011
    Tom
    Lead Developer
    Lead Developer

    The latest update was GP Premium last Thursday, which was 1.6.

    If reverting back to 2.0.1 fixed it, I’m assuming it’s some sort of caching issue.

    #532032
    Julia

    Ok, so after the rollback I’ve emptied every single cache I could find. Minify, database, object, page, etc, all caches cleared.

    Updating the theme back to 2.0.2 and flushing all caches again seems to have solved the issue! Thanks, Tom! Specially for building such a great team and more over to being so patient.

    #532034
    Tom
    Lead Developer
    Lead Developer

    Great news! Glad everything is back to normal now ๐Ÿ™‚

    Thank you!

    #535889
    Julia

    Ok, so now my problem is with the spacing between the header and the content.

    Before it was ok, but now if I had a -% on the margin top to hide the spacing, the menu disappears. I am not sure what happened, but I added the spacing back so people can access the menu. On the elementor preview, it looks ok, but then on the page itself it looks odd. Again, I’ve done all the things we’ve discussed before and nothing changed.

    What can I do to make that spacing go to hell (lol) and still keep the menu (the hamburger icon) visible? thebrandingirl (dot) com, all pages were affected.

    #536274
    Tom
    Lead Developer
    Lead Developer

    Which space exactly? Your site looks great to me?

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.