Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] GP Premium Update error

Home Forums Support GP Premium Update error

  • This topic has 7 replies, 3 voices, and was last updated 5 years ago by Tom.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #156528
    Barbara Lougheed

    When I tried to update the plug-in today, I got an error message and the plug-in disappeared from the list. Here’e the error message:

    The plugin gp-premium/gp-premium.php has been deactivated due to an error: Plugin file does not exist.

    Host says there’s nothing in the error log, but they deleted the file, and I reinstalled my original zip file. When I tried to update again, got the same error message. The file is not in my list for me to deactivate and delete. How do I fix this? BTW, this is the second time this has happened on this site. Oddly, I have GP Premium installed and working on 3 other sites–those update just fine. HELP!

    #156530
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Your host couldn’t find any errors?

    The fact that it’s working on your 3 other sites tells me it might have something to do with the server permissions of the problem site.

    If the plugin file doesn’t exist, that means it’s not being uploaded on update, which is usually a permissions thing.

    Let me know 🙂

    #156536
    Barbara Lougheed

    “server permissions of the problem site”

    I understand what this means in theory, and I think you’re telling me to call my host. But what exactly do I say? Can you tell me specifically what I need to tell them to look for and change? Or is this something I can change myself? Thanks.

    #156537
    rex wickham

    Hi
    I’m seeing this error too.

    You have version 1.2.74 installed. Update to 1.2.76. View version 1.2.76 details.
    Compatibility with WordPress 4.3.1: Unknown

    Updating Plugin GP Premium (1/1)

    Downloading update from …

    An error occurred while updating GP Premium: Download failed. Unauthorized

    In the GP setting screen I have ticks on the email address and the Updates section

    #156538
    Tom
    Lead Developer
    Lead Developer

    Barbara – ask them to make sure WordPress has permission to add/remove/change files on the server. That error tells me it’s allowed to remove files, but something is stopping it from re-adding the new ones.

    Rex – this should help: https://generatepress.com/forums/topic/an-error-occurred-while-updating-download-failed-unauthorized/#post-146895

    #156542
    rex wickham

    this fixed it https://generatepress.com/forums/topic/an-error-occurred-while-updating-download-failed-unauthorized/#post-146895

    This site had moved from a temporary url to another along the way.

    #156626
    Barbara Lougheed

    Well, my host didn’t change any permissions, just restored GP Premium to my plug-in list, and then when I hit update, this time it worked! Puzzled but pleased.

    #156627
    Tom
    Lead Developer
    Lead Developer

    Weird, hopefully it behaves from now on 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.