[Resolved] GP Premium Element PageHero working for FrontPage, but NOT showing on 2nd page.

Home Forums Support GP Premium Element PageHero working for FrontPage, but NOT showing on 2nd page.

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
  • #1252244

    Using latest GP Premium 1.10.1
    Wordpress 5.3.2

    NOTE: I am developing on a local laptop DesktopServer… so there is no WEb access for you to see.

    I am using the “GP Premium” Elements GUI. I have the 1st Page=FrontPage Background image with Parallax working fine.

    I created a 2nd Page. I created a 2nd Page Hero ELEMENT (with just HTML comment in HTML box) & pulled in a DIFFERENT Background IMage into the GUI… fine so far. I Set the Padding to various values for testing… but I just get a black background, with the Primary Menu showing. I see no Background Image. I can see a FeaturedImage if I setup that, but that is not what I want. I ultimately will have 7 pages. I want a different HeroImage for each PageHeader.

    I have tried various permutations of PageHEro Element position, background color, padding etc. No image hero appears on the 2nd Page.

    Also the 2nd Page, “Page Title” is showing, even though I have selected NOT TO SHOW !!!

    Please help.



    … I have also played with various “Site Header” & “Display Rules” values…
    Nothing works for showing the HeroImage on the 2ndPage.

    Customer Support

    Hi there,

    It’s really tough for us to tell without seeing the issue live.

    Any chance you can duplicate the problem on a staging site for us to see?



    …correction, Im using the latest GP Premium version 1.10.0


    … is it possible for you to remote onto my laptop ?????

    Customer Support

    We cannot do that, unfortunately.

    The best solution would be to create a staging site for your set up. It would help if you have any questions in the future as well.


    … I think you can use Zoom ?????

    Customer Support

    We don’t offer remote control for support unfortunately.

    The best solution would be to create a staging site for your set up. Or we can revisit the issue once we have something live to look at.


    Thank you for your responses… I will setup a STAGING SITE… then get back to you !!!

    Customer Support

    Sounds good thank you!


    Hi Leo,

    Here is my Site, so far… http://www.cucme123.com

    I want a different HeroImage Background Header at the top of each page, with Paralax Scrolling.

    Currently Page1 is working fine. When I CLICK on Menu-Play item, the Play Hero on Page2 is not showing. This is all I currently have coded for Page2.

    Here is an AdobeXD design view of my site. Page 1 (far left) is working. Page 2 (next right) is not.
    (sorry I could not discover how to copy/post this image).

    Thanks Leo.


    Here is the AdobeXD design sheets:

    http://www.cucme123.com/wp-content/uploads/2020/ALL Pages FINAL.png”

    Customer Support

    I’m confused.

    So you want the exact same header element but just with a different background image?

    If so can you try using the featured image as the background image option?


    Hi Leo, thanks for all your help so far.

    I am new to WordPress & to GeneratePress, so I appreciate your guidance on this.

    As you can see in my AdobeXD design pages, in the image file: “http://www.cucme123.com/wp-content/uploads/2020/ALL Pages FINAL.png” .

    As I understand how GeneratePress Elements are supposed to be used (& please tell me if there is a SIMPLER way):

    * I need a separate unique Hero Page Element for each WordPress Page

    * I want each Page Hero Element, to have a unique Background Image

    I dont want to use THE SAME header element for all pages. I want a Unique header element for each page.

    So, please tell me 1) if there is a SIMPLER way to do this, or 2) how to get the backgroundImage to appear on my 2ndPage.


    … I should also mention that I am using a GeneratePress child theme, using GeneratePress Site-Library “Mellow” as my base.

Viewing 15 posts - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.