[Support request] GP nav bar won’t go away inside Elementor

Home Forums Support GP nav bar won’t go away inside Elementor

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1340785
    William

    Can you help me understand why I keep seeing the GP nav bar in Elementor, even though I have my own header set to appear on Pages? This is my Page template https://i.imgur.com/UVLYvfl.png. When I preview it, though, the GP nav is removed and everything appears correctly, like so https://i.imgur.com/3BV6ozh.png

    This is a local site – GP, GP Pro, and Elementor are all up to date. I’m using the GP child theme.

    #1340894
    Leo
    Staff
    Customer Support

    Hi there,

    Tough to tell without seeing the issue live unfortunately.

    Is the customizer option set to No Navigation?
    https://docs.generatepress.com/article/navigation-location/

    #1341991
    William

    I created an entirely fresh install on GP on a new staging site and started from scratch. I created my Elementor header and set it to appear on all Posts. When I go to create my Post template in Elementor, the GP nav bar was still there, so I went and disable the nav like you said and ticked no tagline and no site title.

    However, there is still a blank element showing up at the top of the page that doesn’t appear to be from Elementor. Any ideas how to remove it? This is with the canvas set to full width and as you can see my Elementor header doesn’t show either. Screenshot https://i.imgur.com/WSqtzHU.png

    #1342119
    Leo
    Staff
    Customer Support

    Screenshots don’t help with issues like this unfortunately.

    Can you link us to the page in question?

    #1342123
    William

    I think I may have figured it out as I had another issue where GP was showing two featured images. I needed to activate more customize options inside GP then untick the option for GP to show the featured image.

    #1342136
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.