[Support request] Google tag manager not firing any tags.

Home Forums Support [Support request] Google tag manager not firing any tags.

Home Forums Support Google tag manager not firing any tags.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1654643
    Alex

    Hi,

    I’ve been trying to install Google tag manager with a few tags on my website (GP Pro + Elementor).

    I’ve tried to install in both the Theme functions folder on both child theme and parent theme.

    I’ve also tried to install the tag using the element “hooks”, one for body one for head.

    I’ve followed all the guides I can find here but for some reason the tags don’t fire. I can see the code showing in the html.

    Site is https://simplyvideo.io

    functions file

    #1654666
    Alex

    Just to note, I have tried deactivating all plugins and this did not fix the issue. I do see GTM is installed, but I can’t get any of the tags to fire with the theme.

    #1654848
    Leo
    Staff
    Customer Support

    Hi there,

    It’s never a good idea to edit the function.php file of the parent theme – your changes will be erased through updates.

    GP itself is not capable of making the code to not work – it simply adds the code for you using wp_head and wp_body_open which are both WordPress hooks.

    Can you add the function using one of these methods and give it another shot?
    Adding PHP: https://docs.generatepress.com/article/adding-php/

    Make sure all caching and server caching are cleared.

    If that still doesn’t work, you can try the exact same code in a Twenty series theme and see if it works there.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.