[Support request] Google PageSpeed Index

Home Forums Support [Support request] Google PageSpeed Index

Home Forums Support Google PageSpeed Index

  • This topic has 1 reply, 2 voices, and was last updated 2 months ago by Elvin.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2005781
    Jeff

    Hello,

    Through a combination of removing plugins, leveraging CloudFlare and Autoptimize I’ve improved my score from 40 to 85. I’m still struggling with failing first and largest contentful paint, as well as speed index.

    My site it new and only has four post with light image content so I feel like the solution is pretty close by.

    Any thoughts on what more I can do to improve my score? I’m very new to this but looking at the reports it looks there could be something with the font that can be improved.

    Appreciate and help feel free to ask any question.

    https://pagespeed.web.dev/report?url=https%3A%2F%2Fbluemonkeygaming.com%2F

    #2005805
    Elvin
    Staff
    Customer Support

    Hi Jeff,

    Consider disabling lazy load on featured images above the fold.

    You can try David’s recommendation about this here – https://generatepress.com/forums/topic/ensure-text-remains-visible-during-webfont-load-8/#post-1729575

    You may also have to preload your fonts.

    As for the “Eliminate render-blocking resources”, you may want to exclude some css files from being merged by Autoptimize.

    While it’s nice to have fewer requests, loading 1 big lump of css file may be detrimental rather than helpful in performance.

    For “Reduce initial server response time”:

    This one is tricky to deal with as it can be a ‘false negative’ sign of the host being slow to respond. Consider asking your host if there’s something that can be improved. (perhaps move your site to a dedicated server. this may require plan upgrade)

    A wise man once said:
    "Have you cleared your cache?"

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.