[Support request] Google Organic Traffic Drop After Switching to GP

Home Forums Support [Support request] Google Organic Traffic Drop After Switching to GP

Home Forums Support Google Organic Traffic Drop After Switching to GP

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #2312241
    Ivaylo

    I replaced my WordPress Theme with GP on the 09th of August and since then I started seeing a drop in Google Organic Traffic. It’s most severe ( or maybe all of the loss ) in Google Images. See attached screenshot.

    1

    2

    So is there a change in how GP is showing, indexing, and creating a path to images differently?

    Looks like Google is trying to find all those indexed images from the beginning.

    Any thoughts will be appreciated.

    #2312243
    Ivaylo

    Below is example URL

    #2312405
    David
    Staff
    Customer Support

    Hi there,

    GP doesn’t do anything with the images, if you add an image to your post content, then that function is managed 100% by WordPress.

    GP can only adjust the Featured Image in its Blog Settings.

    But we don’t add any code to the Image HTML or any code that would be directly related to image SEO.

    Do you know if you’re previous theme did something specifically regarding Image SEO ?

    #2312434
    Ivaylo

    I’m not aware of any special thing to SEO images from the previous theme.

    It can’t be a coincidence as the drop starts the moment the theme was changed. Anyway, I will keep monitoring GSC to see if it will start to get back to it’s previous state. I suppose images are being recrawled and will be temporarily ditched out of the search results.

    #2312438
    David
    Staff
    Customer Support

    If you change theme, then the HTML being output will change, that in itself can prompt google to recrawl pages. Which may be behind what you’re seeing.

    #2312462
    Ivaylo

    Yes, seeing a huge spike in Google Crawl Rate. All in images – like 30x times normal.

    #2313199
    David
    Staff
    Customer Support

    What was the previous theme you were using ? The most i can do is try and make a comparison between GPs output and that of the old theme. Their maybe something different.

    #2313279
    Ivaylo

    The old theme was Publisher. https://betterstudio.com/

    Would be very grateful if you can make a comparison from your point of view. Thanks!

    #2313330
    David
    Staff
    Customer Support

    I had a look at a couple of their demos. I could not see any noticeble difference.

    They use <figure> and <img> HTML markup which is the same in the core Image block. And both were using alt tags for the image description as well.

    The only thing i can’t speak on is that your current site is using Social Snap sharing . As you can see here, it is modifying the HTML of the images by quite a lot:

    https://www.screencast.com/t/HQG7Q8tsb

    The Green highlighted elements is what WP outputs
    The Red highlighted elements is added by Social Snap
    The Yellow highlighted element is what the core Img element but it has been manipulated by social share.

    Was Social Snap being used on the previous theme install ?

    #2313683
    Ivaylo

    Social Snap was installed before and it is now installed again.

    Thanks a lot for trying to help me. I will just wait for a few more days and will let you know what happened in this topic.

    #2314112
    David
    Staff
    Customer Support

    Ok, let us know how you get on!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.