[Support request] Global Color Palette for GeneratePress & Elementor Pro

Home Forums Support Global Color Palette for GeneratePress & Elementor Pro

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #321361

    I am trying to setup a global color palette that works with GP and Elementor, I don’t want GP to set any of my colors (default colors). I tried the below but that doesn’t carry over to the Elementor color palette, even with Elementor’s Global Colors disabled.

    Anyone know a way to implement a true global color palette? I tried Central Color Palette but it doesn’t quite work.

    I’m using the child theme: http://generatepress.com/api/themes/generatepress_child.zip


    add_filter( 'generate_default_color_palettes', 'tu_custom_color_palettes' );
    function tu_custom_color_palettes( $palettes ) {
    	$palettes = array(
    	return $palettes;
    GeneratePress 1.3.46
    GP Premium 1.3
    Customer Support

    Hi James,

    If you are trying to use Elementor only then you want to enable Elementors global settings for sure.

    The GP filter won’t change Elementors color pallettes. You would have to ask them how to change that for sure.

    Let me know if this answers your question.


    You can’t really use Elementor only to set all colors such as header colors, Nav colors etc. That’s why I was looking for a way to have global custom palette colors. And yes Elementor has a custom palette but you can only set 8 colors.

    I’m going to open another topic, I want to totally disable GP from altering my color palette (Defaults). I think that’s a better way to start.


    Lead Developer
    Lead Developer

    This will do that:

    add_action( 'after_setup_theme','tu_default_color_palettes' );
    function tu_default_color_palettes() {
        remove_action( 'customize_controls_enqueue_scripts','generate_enqueue_color_palettes', 1001 );

    This works for all the single slider color pickers but not the alpha sliders like header background.


Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.