[Resolved] Getting started with the “Service” template

Home Forums Support Getting started with the “Service” template

  • This topic has 14 replies, 3 voices, and was last updated 1 month ago by Mike.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1356704
    Mike

    Hi,

    I have been struggling to build a website for over a week now.

    My initial efforts in free versions of Astra/Elementor proved horribly slow and most people would have gone elsewhere by the time it loaded. So I did some research and after finding the shortcomings of other themes, I decided on Generatepress Premium, which I have been on since Monday.

    I prefer the templates Elementor offer and find them really easy to work with, but GTMetrix gives me really bad loading results on that.

    So I am currently working on a clean install using the Services template from the GP Premium ones. What I need to know is:

    1. How do I replace the background image at the top?
    2. How do I replace the circled S with my own logo?

    I am sure these are really easy changes as they are in Elementor, but I am having a problem.

    Can you also recommend a clear and concise Youtube video on using Generatepress for a beginner.

    Many thanks.

    Mike

    #1356718
    Mike

    I meant to add that the only Plugins in addition to GP Premium are Generateblocks and lightweight social links that the template automatically loaded. As it did not recommend Elementor or Beaver Builder, there are no page builders currently installed.

    #1356877
    Leo
    Staff
    Customer Support

    Hi there,

    1. The top (blue) background image is added within the container block from GenerateBlocks:
    https://www.screencast.com/t/sXYdwXSV2
    https://docs.generateblocks.com/article/container-overview/#background-image

    2. You should be able to change the logo in Site Identity:
    https://docs.generatepress.com/article/adding-header-logo/

    There aren’t a lot of tutorials videos out there unfortunatly – they take a long time to produce and things are always changing.

    We keep our documentation page up to date and all options should be explained there:
    https://docs.generatepress.com/

    Service is built with GenerateBlocks almost completely so this doc might be helpful as well:
    https://docs.generateblocks.com/

    Let me know if this helps or if you have other questions 🙂

    #1356976
    Mike

    Hi,

    Thanks for the reply.

    Icon is sorted but shows old logo on phone, but that will sort itself out.

    I can see GenerateBlocks under Settings, but cannot find Blocks > Containers to change the image with the blue overlay? Please advise.

    I am ok with any page builder for a simple website?

    Thanks,

    Mike

    #1356979
    Mike

    Sorry meant – Am I ok WITHOUT any page builder for a simple website?

    #1356990
    Leo
    Staff
    Customer Support

    You should see the block in the Edit page screen.

    Just click on that block then you should see the options in the right sidebar.

    Am I ok WITHOUT any page builder for a simple website?

    Of course! Page builders are never required for anything. We’d like to think that you can use GB to create any layout needed 🙂

    #1357431
    Mike

    That’s great, slowly getting there.

    Another couple of questions:

    1. I want to change the telephone number and email us to white on a transparent background. I can see how to change the font colour/size etc but not how to change the background. Also, can I use a different font colour in mobile mode where white might be less visible?
    2. In edit mode the logo is updated in desktop and tablet, but still shows the old S in phone mode. In the real world, fine on desktop and ipad (when held held horizontally), but when held normally the old logo reappears. I have checked on 3 smartphones and it’s the old logo.

    Thanks,

    Mike

    #1357887
    Mike

    Another problem.

    Still on home page of the service template.

    The lower container with blue background fade. I have changed the image and text and wanted to fade from dark cyan to light cyan setting the gradient to 150 as with the top container. As soon as I make this change the image and background is lost, leaving only the white invisible text/email link as visible.

    This is making it usuable and I’ve been stuck on it for 90 minutes now trying to figure it out. I change the background colours, it comes back, then I change to blue and gone for 20 minutes.

    #1358076
    David
    Staff
    Customer Support

    Hi there,

    1. You can edit most of the styles in GenerateBlocks.
    But you cannot change the text color for the various device sizes.

    For the background – select the Container Block – in the Settings side bar , select the Gradient option where you can edit the colors.

    2. Logo – go to Customizer > Layout > Header and update the Mobile Header logo.

    #1358120
    Mike

    Thanks, logo sorted on mobile/tablet now.

    The problem I left at 7am your time, is probably related to a more important one I am currently having.

    The last main container that’s plain blue and reads Company history…. can’t be edited? There’s nothing there, just blank. If you click it, it just says start typing to create a container? Have I unknowingly disabled something?

    There’s also a button that I keep trying to delete but keeps coming back at the top of the page?

    Thanks,

    Mike

    #1358154
    David
    Staff
    Customer Support

    The Company History section is the Site footer. You can set its colors in Customizer > Colors > Footer.

    I am not seeing the button ? anywhere particular i should be looking ?

    #1358200
    Mike

    Sorry, web design and me go together like oil and water. Any ridiculous questions are just a foretaste of what’s to come.

    Anyway, the button I mentioned pops up everytime I make any changes. It’s all under control now, but was appearing just above “Ring ABC……”

    How do I add the footer, I know there is one as I have changed the copyright details, just not sure how to get to it…..and I have been trying.

    What the quickest route to load the customizer? Is it the same as customise on the edit page, and what’s the difference between edit page and customise?

    Thanks,

    Mike

    #1358256
    Mike

    OK, I think I have it worked out, just find it a bit flakey.

    #1358747
    David
    Staff
    Customer Support

    Glad to hear that. Hope we can improve on the support going forward 🙂

    #1358897
    Mike

    No problem David, you are obviously really busy, but I am slowly getting there.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.