[Resolved] GeneratePress Premium crashes Customizer

Home Forums Support [Resolved] GeneratePress Premium crashes Customizer

Home Forums Support GeneratePress Premium crashes Customizer

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #572566
    Mike

    I recently updated Elementor to 2.0.11 and ElementorPro to 2.0.5. Now, if I have GP Premium activated, the Customizer page doesn’t load and I get an error message that it failed.

    I have done extensive testing: deactivating plugins, changing themes, etc. The only thing that delivers consistent failures to launch the Customizer is GP Premium. This is unacceptable.

    To be clear, everything was working well prior to my updating Elementor/EPro. Furthermore, the Customizer works perfectly well with other themes, including WordPress 2017 and Astra. This is a GP Premium issue, solely. Please tell me how to fix this as I would hate to have to abandon GeneratePress. Thanks.

    GeneratePress 2.1.1
    GP Premium 1.6.2
    #572600
    Tom
    Lead Developer
    Lead Developer

    What’s the exact error you’re getting?

    It could be as simple as your server running out of PHP memory, which you can increase: https://docs.generatepress.com/article/increasing-php-memory-limit/

    #572661
    Mike

    The memory is set exactly as described in your reply, Tom. Has always been. It’s not working with GP Premium.

    The issue is that trying to launch the Customizer page with GP Premium activated results in a long lag wherein the Customizer items display, but the page remains blank; then a screen with this message displays, “Aw, Snap! Something went wrong while displaying this webpage.” There is a Learn More button and an Reload button. End of story. This happens whenever GP Premium is activated, and doesn’t happen when it’s not.

    As I mentioned earlier, this does NOT happen with WordPress 2017 or Astra, so it’s a GP Premium exclusive “feature.”

    #572664
    Tom
    Lead Developer
    Lead Developer

    We simply have to figure out the specific conflict here. Of course, there’s tons of people using GP Premium along with Elementor and Elementor Pro with no issues, so there has to be something specific to your set up.

    Disable your modules one by one in “Appearance > GeneratePress” – does the Customizer start working? If so, which module is causing it?

    You can also check your error_log file on your server – are there any recent errors?

    #572711
    Mike

    I systematically deactivated/activated the GP Premium modules, and the offending module is “Backgrounds.”

    If it is activated along with either “Secondary Nav” or “Typography” being activated (individually and together), the Customizer page crashes.

    With only “Backgrounds” deactivated and all others activated, the Customizer page loads per normal.

    Is there a fix for this, or is the solution to just not activate the “Backgrounds” module?

    #572778
    Tom
    Lead Developer
    Lead Developer

    Hmm, are there any errors in the error_log file that I mentioned?

    I just tried it (E 2.0.11, E Pro 2.0.5, GPP 1.6.3) with all modules activated. I could access the Customizer without any issues.

    Perhaps the error log has an answer for us.

    Let me know 🙂

    #572840
    Mike

    GPP 1.6.3? I’m using 1.6.2. That’s the latest I can download.

    No error log available. I edited my wpconfig file to turn on debug and log but the errors log doesn’t appear anywhere. If there is a private message feature, I can send you my login creds, if you want to take a look. This has been a snake-but couple of days. I’m ready to shoot this site in the head.

    #572849
    Tom
    Lead Developer
    Lead Developer

    Sorry, I meant 1.6.2.

    Shoot me some temporary login details here and I’ll take a closer look: https://generatepress.com/contact/

    #572862
    Mike

    Thanks, Tom. I sent you a message containing the URL and login creds to my site via the Pre-Sales contact form. There wasn’t any contact form to submit a support question.

    Mike Crixell

    #572983
    Mike

    I discovered that the Dashlane extension I had installed in Safari and Chrome was incompatible with the full complement of GP Premium modules. I disabled the extension in each browser and everything worked as expected. This is a new development that started after I updated Elementor, EPro and GeneratePress. Something in all of that gumbo was causing tech indigestion. Too bad, too, because Dashlane is a great password manager. I’ll just disable it when I’m developing. Thanks for the help, Tom.

    #573386
    Tom
    Lead Developer
    Lead Developer

    Another user reported the same thing.

    I gave it a try and didn’t notice any issues, but perhaps it’s the number of passwords/browser resources: https://generatepress.com/forums/topic/customise-theme-area-crashes-when-launched/#post-573384

    Very strange – I’ll keep an eye on it 🙂

    #881796
    Geoff

    THANK YOU, MIKE !
    This was driving me insane.

    #1141780
    Fearghal

    Just to report I’ve been having the same issue and tried turning off Dashlane in Chrome and it fixed it.

    #1141810
    Leo
    Staff
    Customer Support

    Awesome!

    Glad you were able to find this post!

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.