[Support request] GeneratePress Menu not working correctly with Elementor

Home Forums Support GeneratePress Menu not working correctly with Elementor

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1083444
    Christian

    Hello! I have another problem while working on my website.
    GeneratePress sticky menu is not working properly while browsing pages that are edited in Elementor and that have a vertical parallax scroll effect on images.
    Please take a look at the page I attached.
    Thank you already in advance.

    #1085174
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Did you get this fixed? It seems to be working for me. The page isn’t very long so I had to shorten my browser to test it.

    Let me know 🙂

    #1101104
    Christian

    Hello Tom, I have tried fixing the problem on my own but to no avail.
    The only way to not make the menu header get bugged is to disable the content I have created with Elementor on the “ABOUT” page.

    By going over the about page on mobile and while scrolling down the menu will not appear instantly.

    #1101147
    David
    Staff
    Customer Support

    Hi there,

    GeneratePress sticky menu is not working properly

    Can you give us some more details?

    As a general note Parallax backgrounds can put a lot of strain on the browser and the device, as it requires the viewport to be re-rendered over and over again when the user scrolls. In addition it uses Javascript to detect the movement. All of these things combined can lead to a ‘laggy’ experience and effect other elements that are repositioned using JS eg. the Sticky Nav.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.