[Support request] Generatepress Heading Block Code being ignored by theme

Home Forums Support Generatepress Heading Block Code being ignored by theme

  • This topic has 9 replies, 2 voices, and was last updated 2 months ago by Leo.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1371030
    Chantal

    Hi there,

    I am using the Generatepress Heading in a Gutenberg Reusable Block and the HTML/CSS is being ignored; the H1 code for the theme is being used instead. Tried it in a normal post too and the same result. I can see how it should look in the backend but is not rendering as it should in the front.

    A link to the said page is below. Please look at the sidebar. That’s how the title is rendering, when it should have the following code:

    Text Align: Left
    Font Size: 26px
    Icon: Inline and Center
    Icon Size: 1.5

    Those are the only elements of the block I have amended.

    Not sure what’s happened here, or if there is a conflict somewhere with a plugin but is there a way to override this? Or use the !important property somewhere? I need all my plugins and there is no issue with anything else on the site or in the theme.

    Thanking you in advance! 🙂

    #1371145
    Leo
    Staff
    Customer Support

    Hi there,

    I’m seeing this CSS in Additional CSS field in the customizer:
    h1 {text-align:center;}

    Also couple of things:

    – How are you using GB in sidebar currently?

    – The sidebar title should not be <h1> as you already have an <h1> Musicals In Aberdeen on that page.

    #1371162
    Chantal

    Hi Leo, I have deleted that line from the customiser but the issue prevails.

    Even if I change the tag to H2 or H3 it doesn’t change.

    #1371163
    Chantal

    I’ve cleared cache etc and it’s still the same, the theme seems to be ignoring the heading block code.

    #1371170
    Leo
    Staff
    Customer Support

    How are you using GB in widgets? It shouldn’t be possible for now but it will be in the next version of GP Premium with the new block elements module.

    #1371189
    Chantal

    I have the heading in a Gutenberg Reusable Block which gives a shortcode and that is in the widget.

    The Generateblocks Heading was the title of the Reusable Block.

    #1371197
    Chantal

    But like I said, even if I use the block in a post or page (I tried in both – it isn’t just a widget issue) I get the same result; the code is being ignored. Any idea what the issue could be? Why would the theme be overwriting it?

    #1371224
    Leo
    Staff
    Customer Support

    It just looks like GB is style is not even being loaded.

    Are you using a plugin called Snow Money Editor?

    Looks like it could be causing the issue.

    We haven’t had other reports on this so some debugging steps are required.

    Can you try doing the following:

    – Disable all plugins except GP Premium and GB.

    – Start a new post with some GB content so I can see try to determine what is causing the issue.

    #1371241
    Chantal

    Hi Leo, I just disabled it on my site and the issue was still there. As this site is live I can’t disable all the plugins but what I am going to do is set up a staging site and give you access. I won’t be able to do it this evening, but I will do it tomorrow. There is definitely something up and I am stumped!
    Thanks for your help. Would you be able to enable a secret link field or similar so I can supply you the details when I have them?

    #1371245
    Leo
    Staff
    Customer Support

    You can just edit the original topic and update the link to the staging site link and comment here again 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.