[Resolved] Generatepress and Custom Post Type Issues

Home Forums Support Generatepress and Custom Post Type Issues

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1119066
    ercios

    Hello

    Maybe this has become a topic before but it is almost impossible to find the right answer for the question since the search brings hundreds of pages as results. I checked some first initial results but I got lost. This is my first post here so please bear with me.

    I have a site and I have several custom post types there. My permalinks are also based on categories. But unfortunately GP does not show tags and categories for custom post types. Moreoever, the permalink structure is also different since GP ignores custom post type categories.

    But everything okay if I use ordinary POST structure as my main post type.

    I will be happy to find a solution. Thanks

    #1119442
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    GP itself doesn’t have any control over custom post types. In order for your custom post types to support categories and tags, you need to set them that way: https://wordpress.stackexchange.com/a/7140

    You’ll see the taxonomies option where you can tell it which taxonomies to use.

    Let me know if you need more info 🙂

    #1119560
    ercios

    Sorry but nothing changes when I do those useless solutions. Moreover the plugin I used to set custom post types “is Custom Post Type UI” and support for tags and categories and more have already been applied just to make that custom post type almost same as posts. So this is a bit or much more a bit related to generatepress even though you deny it IMHO. This should be a common problem for many people using generatepress. How did they solve this? Is it so hard for you to tell me and everyone a solid solution?

    No offense but instead you say “we are not into custom post types. Go find your own solution”. I am really speechless to see such a low level help. Here your documentation covers adding columns to custom post types: “https://docs.generatepress.com/article/using-columns-in-the-blog/#adding-columns-to-your-custom-post-type”. My situation is no different than that.

    So as a customer of yours, I kindly ask you find a solution PLEASE. This is really important for me. All my site is based on using custom post types and using generatepress as my theme.

    Thanks

    #1120107
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I’m trying to help you find a solution. I wasn’t aware that you were using that plugin, so I found the solution for this issue when creating the custom post type from scratch.

    So, if you’re using that plugin, make sure these checkboxes are checked: https://www.screencast.com/t/u8fQDWr4hhkQ

    Now that I’ve created my custom post type, and checked those options, I’m able to use categories and tags in my posts: https://www.screencast.com/t/nBY5vqYJerqy

    I just tried this using the latest version of GP and GPP, and it worked as the plugin advertises.

    Let me know if this helps or not 🙂

    #1120252
    ercios

    Hello

    No it does not help because I have already said that I have done all those stuff. I can see tags and categories in “edit post” page but tags and categories do not show up when post is displayed. That is my problem. I am sure there should be a solution for that.

    Do you need login info for my site?

    Thanks

    #1120263
    Tom
    Lead Developer
    Lead Developer

    Ah I’m sorry, I misunderstood.

    Can you try adding your post type to this filter?: https://docs.generatepress.com/article/generate_footer_meta_post_types/

    Sorry again for all the confusion – hopefully this does the trick 🙂

    #1121008
    ercios

    Hello

    I tried that filter thing but I do not know If I have done it right because at first I tried to add it to theme functions file. WordPress gave error. Then I used your suggestion code snippets plugin. Added and activated that plugin and I added that filter there. No change.

    I sent my site login details via email. I hope you can see it. Below are two images showing custom post type facility has no tags and category while default wordpress hello world post shows tags and category.

    IMAGES:
    Custom Post type Facility showing no tags and category
    Default hello World Post

    #1121105
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I just adjusted the filter to include your post type – looks like it’s working now.

    Let me know 🙂

    #1122400
    ercios

    Hello

    It worked!!!

    Thanks a lot. You cannot imagine how much valuable your help to me. I am grateful for your kind replies.

    Just a note: As you know this happens for ever GP user having custom post types. Maybe you should include this solution in your documentation.

    Thanks again. I wish you and your loved ones a great happy new year.

    #1122816
    Tom
    Lead Developer
    Lead Developer

    Awesome, glad it worked! 🙂

    Happy New Year to you and your family as well!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.