[Resolved] Generateblocks not working randomly

Home Forums Support Generateblocks not working randomly

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1441776
    Alessio

    Hey,
    few things are not working correctly on my site with generateBLOCKS. For example, I have two containers in a grid, both set to 50% width.
    The CSS code for the 50% width-containers is completely non-existant though and they’re both using 100% width…
    I don’t know why, but the CSS code for 50% isn’t being generated anymore, even though it should. I can’t find it in the html explorer in chrome either.
    I’ve tried updating it, re-setting it or clearing the cache — no luck.
    I’ve done the exact same thing in the about us page of my website and that worked.

    I’ve temporarily “fixed” it by hardcoding the 50% width as CSS (it’s in the html code above the interview box), but other things like the padding of the interview questions and answers are still messed up, even though everything is set in the generateblocks block options.

    So, in short, generateblocks is ignoring some block options I have set for no apparent reason, even though the same settings work on some pages.

    Maybe, adding the whole block as a reusable block creates that problem? Because that’s what I did and it has worked fine before I did that. Just a guess, though.

    Could you please fix that? Thank you! It happened more than once now.

    #1441783
    Alessio

    Example:

    That blue-highlighted box which I selected is supposed to have a width of 87%. I’ve set the width to 87% in the GenerateBlocks options, you can confirm that.
    However, that just didn’t make it to the actual CSS-Code — that’s why that box is so small.
    Note that the width-CSS for that is hard-coded on screen sizes smaller than 990px.

    #1441850
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can disable the caching plugin so we can take a closer look at the code?

    The re-useable block is handled by WordPress/Gutenberg and can definitely create some weird issues like this.

    #1441946
    Alessio

    Hello,

    is it fine if you can just try cleaning the cache? I don’t wanna lose the settings of my caching plugin.
    You can do that under Settings > WP Rocket > Clear cache. That should clean the Runcloud nginx cache too.
    If you’re logged in, the cache should be disabled anyways.

    Thank you!

    #1441955
    Leo
    Staff
    Customer Support

    I don’t think I’m seeing the issue here:
    https://www.screencast.com/t/NBej38BHfR

    I believe that’s working correctly? Also noticed that the next column is set at 12% so the total is 99%?

    #1442445
    Alessio

    Uhhh…. that’s weird, it seems to be working now.
    That’s how it looked like yesterday:

    (the image in the intervieweeBox was also set to 100% width as you can kind of see in that image.)

    It has also looked the same for other people around the world visiting my website (so it wasn’t just my browser cache). And yes, I did clean my WordPress cache(s) multiple times yesterday.

    I don’t know what happened but it fixed itself overnight.
    That’s not the first time this happened though, so there may really be a problem with reusable blocks or caching — I’m not sure.

    #1442461
    Leo
    Staff
    Customer Support

    I’m guessing it’s caching 🙂

    Glad it’s working.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.