[Resolved] Gap between pages

Home Forums Support [Resolved] Gap between pages

Home Forums Support Gap between pages

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1588821
    Mathias

    Hi,

    I’m working on a website for an Hotel (with the starter theme Vacation and the plugin GenerateBlocks).

    All is fine but there is a gap between different pages.

    By gap I mean that main navigation and the top of the content (H1) are not at the exact same place on each page.

    Can you help me please ?

    Thank you for your help.

    #1589422
    David
    Staff
    Customer Support

    Hi there,

    You have a Header Element, found in Dashboard > Appearance > Elements that is set to Merge with Content for your Home Page:

    https://docs.generatepress.com/article/header-element-overview/

    The merge setting pulls the page content up and under the site header, and is generally used when you want a transparent site header over an image for example. It doesn’t look like you need this so you can delete the Header Element.

    Any other differences in height will be related to a the padding / margins you have set in the GenerateBlocks Containers etc.

    #1589471
    Mathias

    Thank you.

    I deleted the Header Element.

    But I still have this differences beetween pages, even with the sames padding / margins set in GenerateBlocks containers…

    And the problem is also in the main navigation. We can see it when we leave a page to another.

    #1589696
    Leo
    Staff
    Customer Support
    #1589720
    Mathias

    Thank you for your answer, but this is not my problem.

    It’s pretty hard to explain and I haven’t got a very good english, sorry.

    For exemple, when you go from homepage to “LE VILLAGE”, the logo and even the navigation menu are not at the exact same place on both pages… And I don’t understand why. It’s only a few pexels.

    Do you understand what I mean ?

    Thanks.

    #1589994
    Leo
    Staff
    Customer Support

    Ahh. The change you are seeing is actually the width of the browser scroll bar.

    If you add more content so that the LE VILLAGE also has a scroll bar then the issue should fix itself.

    Let me know if this makes sense πŸ™‚

    #1590179
    Mathias

    Yes that’s it πŸ™‚
    Thanks a lot for your help and your time.

    #1591365
    Leo
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.