Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Support request] Function "the_content" not found in actual template

Home Forums Support Function "the_content" not found in actual template

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #387279
    Jordan

    Hello there!

    I am having some trouble with Elementor and Generate press.Whenever I try to add a new page and I get the following error with Elementor: “You must call the function “the_content” in the actual template so Elementor could work on this page.However when I edit a page with Elementor it works correctly.

    According to Elementor Documentaion this problem might be because of a WooCommerce conflict, so I tried deactiviting the plugin, but still doesn’t work…So I guess It’s not a WooCommerce conflict.

    The other issue that they state it’s because the function the_content is missing,so I cheked the following file “content_page.php” and effectively they it has the “<?php the_content(); ?>” function…

    Any ideas of what could be the problem? Before I couldn’t even edit the pages, but after reinstalling Generate Press, at least now I can edit the actual pages with elementor.

    #387419
    Tom
    Lead Developer
    Lead Developer

    This is a pretty common issue in Elementor – I wish they would update the message to be more helpful.

    GP includes the_content() function everywhere that it should, so this error is usually caused by:

    a) Trying to use Elementor on a non-static page (blog, woocommerce shop index etc..)
    b) I’ve seen something about the .htaccess file causing issues sometimes. This would be something you need to ask Elementor support though.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.