[Resolved] Full-width section

Home Forums Support Full-width section

  • This topic has 7 replies, 3 voices, and was last updated 2 months ago by Leo.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1376148
    Andy

    Hi,

    I’m using GeneratePress along with GenerateBlocks but still getting horizontal scroll when using a full-width block. I was under the impression that using Generateblocks would resolve this or will I still need to use the overflow-x CSS fix?.

    #1376319
    Leo
    Staff
    Customer Support

    Hi there,

    I’m seeing Kadence block mixed in there as well.

    Do you know which block is causing the issue specifically?

    #1376616
    Andy

    Hi,

    I’ve removed the Kadence Block now. It happens when you make any block full-width, I’m using the GenerateBlocks Section block set to full-width for the full-width image and the full-width purple section.

    This also use to happen when sertting the native cover block to full-width but I read somewhere that Tom said using his new GenerateBlocks section should avoid the issue. Also tried setting the Page Builder option to full-width, but that didn’t help.

    #1376765
    David
    Staff
    Customer Support

    Hi there,

    the AlignFull and AlignWide options displayed on a blocks toolbar are a terribly hackish way to make elements extend the full width of the screen. They work, until you start adding content within that may increase the elements width.

    Best method is to NOT USE them.
    Instead set your Page Builder Container to Full Width.
    Then slice up your page using the Container Block. You can set them to be Full Width or Contained from the Settings Sidebar. Just do not use them with toolbar options.

    #1377232
    Andy

    I’ve just tried turning off the AlignFull options on the sections and just used the full-width options in the block settings, but still getting the horizontal scroll unfortunately.

    #1377428
    Leo
    Staff
    Customer Support

    I’m still seeing Kadence block there which is a bit difficult identify what’s going on.

    David’s suggestion should work though.

    Are you able to determine which block is causing the issue by temporarily removing some of them?

    We’ve been using full-width blocks for quite a few sites in the library

    Let me know 🙂

    #1378506
    Andy

    Sorry guys, I’d left some negative margins on one of the blocks, all working fine now!.

    #1378552
    Leo
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.