Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Full page background for Main Post and Single Post pages

Home Forums Support Full page background for Main Post and Single Post pages

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #403662
    Joseph

    I used the following to set the background (full page) image on my blog page and single posts. It worked fine but now it has disappeared. Is this the correct CSS.

    body.blog {background: url(‘https://provinciawebdesign.com/wp-content/uploads/2017/07/blog_bg.png’) no-repeat center center fixed;
    -webkit-background-size: cover;
    -moz-background-size: cover;
    -o-background-size: cover;
    background-size: cover;
    }
    .single.separate-containers {background: url(‘https://provinciawebdesign.com/wp-content/uploads/2017/07/blog_bg.png’) no-repeat center center fixed;
    -webkit-background-size: cover;
    -moz-background-size: cover;
    -o-background-size: cover;
    background-size: cover;
    }

    Thanks in advance.

    GP Premium 1.4.3
    #403745
    Leo
    Staff
    Customer Support

    Hi there,

    The CSS looks good. Something had to happened for it to stop working.

    Can you link me to the pages?

    Thanks!

    #403811
    Joseph

    https://provinciawebdesign.com/blog/

    and any of the single posts within.

    Thanks!

    #403812
    Joseph

    Leo forgot to mention the background is visible on firefox but not Chrome.

    #403853
    Leo
    Staff
    Customer Support

    It’s not visible on firefox or chrome for me.

    Can you try inserting the full link to the background image?

    This is what I currently see:

    body.blog {
        background: url(//cdn.provinciawebdesign.com/staging/wp-content/uploads/2017/07/blog_bg.png) no-repeat center center fixed;
        -webkit-background-size: cover;
        -moz-background-size: cover;
        -o-background-size: cover;
        background-size: cover;
    }

    which doesn’t seem to link to anything.

    #403857
    Joseph

    Yes correct, it’s gone from Firefox again.

    Here some screenshots of the Child CSS and the Media file
    https://provinciawebdesign.com/wp-content/uploads/2017/07/blog_bg.png

    CSS screenshot link:
    https://provinciawebdesign.com/support/css.png

    Media screenshot link:
    https://provinciawebdesign.com/support/Media.png

    Leo, I did create a subdirectory https://provinciawebdesign.com/cdn to serve static content from a cookieless domain. I wanted to increase load time as recommended by https://tools.pingdom.com speed test.

    That may be the issue

    #403899
    Tom
    Lead Developer
    Lead Developer

    Something seems to be changing the background image URL to this: //cdn.provinciawebdesign.com/staging/wp-content/uploads/2017/07/blog_bg.png

    That doesn’t link anywhere, which is likely the issue. Any CDN plugins?

    #403909
    Joseph

    I do use the Fast Velocity Minify plugin so I disabled the CDN and got the image to work on Firefox and on the single pages for Chrome not the main post page. I purged the Cache also. I will reach out to the author of the plugin and see what is going on. Once I find the solution, I’ll post it here hopefully helping others with the same issue in the future.

    Thanks, you guys are the greatest!!

    #404200
    Leo
    Staff
    Customer Support

    Sounds good 🙂

    Glad we could help!

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.