[Resolved] Footer spacing

Home Forums Support Footer spacing

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1391402
    Lars

    Hi,

    I’m building the footer with the block element and it’s going pretty well.

    But I have two issues.

    I have a grid with two columns at the bottom (split 50/50) with the copyright to the left and social icons to the right.

    In the back-end it looks fine – but in the front-end the social icons get squeezed into the copyright part.

    Another issue I’m struggling with is how do I remove the tiny amount of white space at the bottom of the page. There is no margin in the footer block but there still comes a stripe of white space below it on the page.

    Thanks for any advice!

    #1391424
    David
    Staff
    Customer Support

    Hi there,

    can you provide a screenshot of how it should look?

    Edit your block element and delete the empty paragraph block at the bottom.

    #1391961
    Lars

    Thanks!

    Sure. Here it’s how it looks like in the front-end when logged-in: https://ln2.sync.com/dl/124648120/h68jhjqz-d9huf9cr-dqesfg2a-n2mwvypq

    But I just noticed the icons are correctly placed when I’m not logged in. Not sure why that is – but it doesn’t matter very much – as long as it looks fine for visitors.

    #1391997
    Lars

    Everything seems to work fine on the entire site except for on this page for some reason where the footer is broken: https://agenturer.no/advokatbistand/

    I thought it was related to the Asset cleanup plugin but doesn’t help to deactivate it.

    Do you have any idea why there is an issue on this page? Shouldn’t be anything special about it.

    Thanks for any advice.

    Kind regards
    Lars

    #1392008
    Leo
    Staff
    Customer Support

    Any chance you can disable all plugins except GP Premium to eliminate conflicts from other plugins first?

    Let me know 🙂

    #1392049
    Lars

    Yes. It’s the same issue on the staging site.

    I deactivating every plugin there (except GP and GenerateBlocks) and the footer is still broken:

    https://agenturer.no/new/advokatbistand/

    It’s just a quick test footer – but the alignment of the buttons and background is not there as on the other pages.

    Very strange. Let me know if you have any idea why.

    Kind regards
    Lars

    #1392112
    Tom
    Lead Developer
    Lead Developer

    It seems none of the GenerateBlocks CSS is being generated.

    What happens if you turn on Inline Embedding as the CSS print method in “Settings > GenerateBlocks”?

    #1392119
    Lars

    Changed to Inline Embedding now but still the same.

    Also tried to click the “Regenerate files” but no effect.

    But the footer looks fine on all other pages.

    Very strange.

    #1392127
    Lars

    Solved.

    I removed all the text from the page – and updated the page.

    Then the footer came back.

    Now idea why it worked but happy it did.

    Thanks for your great help and support!

    Have a wonderful weekend!

    #1392134
    Lars

    OK. I have pinpointed the exact cause of the problem.

    Inside the text block there was the following code:

    <p><!– /wp:paragraph –><!– wp:paragraph –></p>

    Not sure what it was doing there or how it got there. But when that is removed it works fine – and when I put it back in the issue reappears.

    #1392182
    Tom
    Lead Developer
    Lead Developer

    Glad you got it sorted – thanks for letting us know 🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.