[Resolved] Fontawesome webfont redirect error

Home Forums Support [Resolved] Fontawesome webfont redirect error

Home Forums Support Fontawesome webfont redirect error

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #227087
    sophia

    Hello Tom,
    I recently moved my https site to a new host. On the previous host I did not receive any webfont errors on pingdom on any pages even if queried with http, www. or just my domain name. After the move, if i query with
    http on my homepage I am ok. If i query on all the other pages with http I get fontawesome webfont errors: My request header on pingdom for fontawesome says “origin of my site is http”. My general settings in wpress are https. Do you have any suggestions? Thanks for your help, ss

    #227143
    Tom
    Lead Developer
    Lead Developer

    Hmm, that’s strange. Your scripts should be loaded from whatever URL you have in “Settings > General”.

    However, this article might help: http://stackoverflow.com/questions/26125030/font-awesome-icons-not-showing-in-chrome-a-maxcdn-related-cross-origin-resource

    #235793
    sophia

    Hi Tom, I had wp rocket look at this. The error was caused by elementor. It seems many of the page builders caused this error. Rather than wrestle with plugins and work arounds, I am trying to rely on GP only. However, I am finding that some of the premium add ons are difficult to understand / execution is not stable. If you ever hold any paid webinars I would love to join!!

    I had similar errors with sections and the header add on. (xtra padding ) Can you please tell me how to eliminate this padding issue with images using lgc in sections? I found that columns works great with text, but with images I always get a padding issue beneath a larger file. I have spent hours trying to eliminate the padding. What is the secret?
    ps. i was hoping to upload an image? I did try some of the css suggestions in the forum but they did not work for me.
    Thanks,
    sophia

    #235861
    Tom
    Lead Developer
    Lead Developer

    That’s odd, those plugins are messing with the URLs? I can’t really think of how they would, I’m curious to hear why WP Rocket thinks so.

    Voice tutorials are on the way ๐Ÿ™‚

    Can you show me the issue you’re having with images? I’m sure it’s an easy fix.

    #253750
    sophia

    Hi Tom, my apologies for the really long, overdue response. I has some critical computer issues and I had to replace my computer, totally unexpected and had to do alot of homework.
    If i remember correctly, the padding issue was only an issue on smaller screens – maybe a responsive issue? I did set up another page – and the padding issue seems to have disappeared since i last tried. However, i was not able to get the header photo to resize no matter what i did (using the full width option) Is there a max width/ size you suggest? The page i set for you is ottomanluxury.com/tomtest/

    i am using both the header and sections on this test page

    I will dig up my wp rocket email and follow up with you

    cheers,
    sophia

    #253758
    Tom
    Lead Developer
    Lead Developer

    You can try adding this CSS:

    .generate-content-header {
        background-position: center center;
    }

    However, the text will most likely not be responsive, as background images aren’t totally responsive.

    You’re better separating the background from the text (two images), and placing the text image as a static image on top of the background. That’s the only way you’ll get a truly responsive area.

    #256047
    sophia

    Thanks for the css tip Tom.
    As for the webfont redirect error i received on pingdom, this was the reply I received from wp-rocket:

    “Indeed, the issue is still there on some pages and I see where it is coming from. The problem is from Elementor page Builder plugin that calls fonts via http all the time. Contacting them would be good idea if our HTTP to HTTPS redirection doesn’t help.”

    Oddly i don’t remember having this error on my last host in august. My site has always been https and my domain is listed as such in the wpress panel. I also have an ssl certificate. At the same time, i only started using gp for a short time before i changed hosts, previously I was using headway.
    I am not using elementor right now, but if i run a pingdom test using http instead of https , then i am getting a webfont error naming a gpress file (before it was elementor) . I am getting this error on every page , except for the homepage. On the homepage i can use http and i do not receive an error.

    Before contacting you I did go through troubleshooting with siteground – the new host. I can see that the http to https redirection would work, but i just want to make sure that i solve the right problem.

    Thanks for your help Tom!!
    sophia

    #256074
    Tom
    Lead Developer
    Lead Developer

    The URL to Font Awesome in GP uses your URL set in “Settings > General”.

    Are both of those URLs set to https://?

    #257497
    sophia

    Hi Tom, yes they are both https
    Sophia

    #257568
    Tom
    Lead Developer
    Lead Developer

    Then you must have a plugin altering it – GP uses the get_template_directory_uri() function to grab the URL to your theme folder, which is set by WordPress using your URL set in Settings > General”.

    #259539
    sophia

    Ok , Thanks Tom , I will look into it further.
    Happy New Year!
    sophia

    #259543
    Tom
    Lead Developer
    Lead Developer
Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.