[Resolved] Font displays different on desktop and mobile

Home Forums Support [Resolved] Font displays different on desktop and mobile

Home Forums Support Font displays different on desktop and mobile

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2005696
    Robin

    Hey there – I have enabled the new Typography system. My body font is Inter and H1 and H3 font is Lora.

    However they do not display on mobile devices only on desktop. My site is – eatweeds.co.uk

    Could you help me out, please? Thanks.

    #2005703
    Elvin
    Staff
    Customer Support

    Hi Robin,

    Can you share a screenshot of this occurrence for both mobile and desktop?

    I’ve tried checking the site on desktop and my android phone and they seem to both use Lora,serif.

    Note: Make sure to clear all forms of cache so the latest changes would reflect on your end. πŸ™‚

    A wise man once said:
    "Have you cleared your cache?"

    #2005950
    Robin

    I have cleared the cache on both my site and on my CDN and still nothing.

    The fonts don’t show on mobile.

    Anything else I can do? This has only happened since I enabled the new Typography system and there doesn’t appear to be any documentation on this new typography system.

    What am I missing? TIA.

    #2006084
    David
    Staff
    Customer Support

    Hi there,

    I can see Lora loading, but not Inter on either desktop or mobile. The request for Inter is not being made.

    In the Customizer > Typography. The top panel titled Font Manager, is the Inter font listed there ?

    #2006090
    Robin

    Hi David,

    Yes it is, please see this screenshot.

    And the snippet that used to install it is turned off, see here.

    #2006116
    David
    Staff
    Customer Support

    Was the Inter font originally installed locally ?

    #2006148
    Robin

    Yes it was originally. I’ve just checked ‘Media’ and cannot find it in there. I’ve also gone into ‘Uploads’ via FTP and don’t see it in there.

    #2006225
    David
    Staff
    Customer Support

    Odd… updating the theme or enabling the new typography option wouldn’t have interfered with the media files or any child theme settings.

    Are you wanting to serve them locally ? If not can you edit the Inter font in the font manager and check the Google Font toggle.

    #2006260
    Robin

    The Google font toggle was already selected.

    However, I unselected it. Searched for Inter. Selected it and turned back on the Google toggle.

    It seems to have reset everything as now the Inter font shows on my mobile devices.

    Thanks for your help, as always, David. Got there in the end πŸ™‚

    Have a good day.

    #2006269
    David
    Staff
    Customer Support
    #2022521
    Robin

    Hi there,

    I have just tried to set my font to Libre Baskerville, yet the same problem that I mention above is happening again. It does not show on any devices.

    When I toggle the Google font on/off/on, nothing happens. Libre Baskerville does not show on any of my devices, only the ‘serif’ font.

    Could you help me please? Thanks.

    #2022578
    Elvin
    Staff
    Customer Support

    I see it being used by the site’s CSS but the font itself isn’t being loaded from Google fonts.

    Can you try clearing your cache again? So the @font-face importation updates the entries and adds Libre Baskerville to the request.

    Let us know how it goes.

    Note: It’s good practice to clear all forms of cache everytime you make a change so a new cached file is generated with the newest changes.

    A wise man once said:
    "Have you cleared your cache?"

    #2022825
    Robin

    Wonderful, Elvin. That worked. I had to clear the CDN cache rather than just the site cache.

    Note to self: Always read the support staff’s signature line πŸ™‚

    All the best.

    #2028371
    Elvin
    Staff
    Customer Support

    Glad you got it sorted. No problem. πŸ˜€

    A wise man once said:
    "Have you cleared your cache?"

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.