[Resolved] Font color issues

Home Forums Support [Resolved] Font color issues

Home Forums Support Font color issues

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2178688
    Erin

    I have what feels like such a basic problem but it’s been consistent for months.
    Sometimes when I view my page, the font color (using the GP headline block) on cover images displays as black when it should be white. When I go in to edit it, thinking it’s a user error, it’s definitely set as white. It’s not ALL the time but it’s most of the time and it has me banging my head into the wall.
    Any tips???

    #2178889
    David
    Staff
    Customer Support

    Hi there,

    some of your page is built using WP Cover Blocks, and inside them are GB Container Blocks and Headline Blocks.
    The problem with that is the WP Cover Blocks have a lot of CSS that can trickle down to its content.

    Is there any reason for the Cover Blocks, when you can just use the Container Block ?

    #2178990
    Erin

    Ahhh ok!! Honestly no reason except it felt easy at the time. I tried to first re-create the same thing with just a container block but couldn’t figure out how to make it cover the entire screen full bleed like I could with the Cover Block. Can you help with that?

    #2178998
    Ying
    Staff
    Customer Support

    Hi Erin,

    To make the GB container go full width:

    1. Set the page’s content container to full width using the layout metabox:
    https://docs.generatepress.com/article/layout-metabox-overview/#where-is-it

    2. Set the the GB container’s outerand innercontainer both tofull width.

    #2179699
    Erin

    Thanks so much!! Completely re-did that page, and it’s so much easier this way. As always, thanks GP!

    #2180132
    Ying
    Staff
    Customer Support

    No problem 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.