[Resolved] Font Awesome and Beaver Builder

Home Forums Support [Resolved] Font Awesome and Beaver Builder

Home Forums Support Font Awesome and Beaver Builder

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #616914
    mackiecompany

    Hi

    I’ve recently had an issue with Custom Post Fields in BB not working properly.
    BB replied and tracked down the problem to a Font Awesome Snippet I’m using on Generate Press.
    Please see below for details.
    What would you recommend as a word-around.
    Thanks
    Scott

    Scott Mackie sent a message Jul 5, 11:04am
    I’ve been using Custom Post Fields in BB but they’ve stopped working twice recently.

    I have an older test site here:
    http://sg-demo.getondigitaldesign.co.uk/ they stopped working and I manually rebuilt the site again with a fresh wordpress install.

    New test site is here:
    http://sg-demo1.getondigitaldesign.co.uk/

    They have been working fine for 5 days but not I can’t use Custom Fields. The + symbol does nothing.

    Jamie replied Jul 5, 12:34pm
    Hey Scott,

    This is caused by this snippet: http://sg-demo1.getondigitaldesign.co.uk/wp-admin/admin.php?page=edit-snippet&id=4

    BB uses the CSS way to implement Font Awesome 5 icons and the CSS and JS way are not compatible with each other, I’m afraid.

    What is the purpose of that snippet – just so that the icons can be used anywhere?


    Jamie VanRaalte
    hello@wpbeaverbuilder.com

    GeneratePress 2.1.3
    #617040
    David
    Staff
    Customer Support

    Hi Jamie,

    is it this snippet referred here that you have added?

    https://docs.generatepress.com/article/font-awesome/

    #617277
    mackiecompany

    Yeah thats the one.

    From BB

    Jamie replied
    Jul 6, 6:55am
    Hey Scott,

    The icons inside the builder for the row settings and such were a little wonky so that was my first clue. In general, you could use a similar snippet and just use the CSS way to load the font awesome icons so they load on all pages but hopefully GeneratePress can help you there 🙂

    #617285
    David
    Staff
    Customer Support

    Hi Scott,

    talking to a BB user, he currently does not use the FA 5 as their are issues with the code the maxcdn is spitting out. So he uses FA 4 icons instead and doesn’t seem to have a problem or require the code snippet.

    Is this a solution?

    #617360
    mackiecompany

    Hey David

    So use FA4 ?

    What would I need to do in GP.

    Thank You
    Scott

    #617370
    David
    Staff
    Customer Support

    Hi Scott,

    (i hate giving 3rd party advice, but i am not a BB user). You shouldn’t need to do anything with GP. Just set BB to load FA 4

    https://kb.wpbeaverbuilder.com/article/645-font-awesome-5-icons

    And if your using FA icons in markup then make sure you use the 4.7 icons not 5.

    #617819
    mackiecompany

    Hi David

    I tried using just FA 4 but doesn’t work.
    Why isn’t Generate Press not compatible with such an major icon font, it should be.

    Regards
    Scott

    #617834
    David
    Staff
    Customer Support

    Have you made sure the icons you are using are FA 4.7 icons when using FA4 only?
    The problem is the way FA is being deployed within BeaverBuilder, not GP. Its not even BB’s fault. The MaxCDN that FA uses gets its wires crossed so it initially imports FA5 icons (when there is a BB section containing them) but on other pages (where there isnt a BB section) it pulls in FA4 which breaks as the two are not compatible.

    #617848
    mackiecompany

    Hi David

    Apologies chrome didn’t save (FA 4 )it down properly. It’s working now.

    Bloody chrome, I’ve had so many issues with chrome latetly. Don’t know if you are aware but on a big WordPress website I can’t use the customiser on chrome it crashes. Started using Firefox and Safari.

    Conflicts man!

    Have a superb weekend.

    Scott

    #618469
    David
    Staff
    Customer Support

    Glad to hear you got it resolved

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.