[Resolved] Filter widgets not showing

Home Forums Support Filter widgets not showing

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1422842
    Lars

    In the past it worked and I cannot find out why not anymore.
    In my shop page https://www.evcreate.nl/shop/ I use the left sidebar with some widgets.
    Unfortunately the following widgets do not show:
    – Active product filters
    – Filter products by price
    Not even a trace in de HTML / CSS, when I inspect.
    I have checked and tested the following:
    – That page is set as the “shop page” in WooCommerce > Settings > Products
    – Disabled all other plugins but Woocommerce and GP
    Any thoughts on what I can do?

    #1423123
    Leo
    Staff
    Customer Support

    Hi there,

    Do you still see those widgets in the left sidebar widget area?

    Let me know 🙂

    #1423130
    Lars

    Yes, in the admin area (as well as via customize) they are there.
    The others do show, but these two don’t.
    Sidebar
    PS. Some are duplicated, one for English, one for Dutch

    #1423135
    Leo
    Staff
    Customer Support

    Hmm that’s pretty strange.

    Can you clear your caching plugin and disable all plugins except GP Premium and WooCommerce for us to take a look?

    #1423222
    Lars

    Did that only briefly on my live site.
    I have created a staging site on https://staging.evcreate.nl/shop/
    One more plugin is active (Hide my site) to make sure it is not indexed)
    Please enter generatepress to view the frontend
    So now only active plugins are:
    – Hide my site
    – GP Premium
    – Woocommerce
    In absence of WPML the widgets intended for a certain language are now all shown (but still not the filter ones).

    #1423251
    Lars

    I stripped my staging down even further:
    – Removed all elements
    – Deleted all out of stock products
    – Deleted all discount products
    – Kept only English products
    – Deleted all custom CSS
    – Tried reverting back to GP Premium 1.10.0

    Still the filter does not appear….

    When you make a change, it shows briefly where it should appear

    View post on imgur.com

    #1423256
    Leo
    Staff
    Customer Support

    That is super strange. Can’t think of anything that would cause this.

    What if you insert that in a footer widget?

    If that still doesn’t work, can you activate a twenty series WP theme and see if the widget works correctly there?

    #1423283
    Lars

    Did not help either. Last thing I could think of was that it had to be a Woocommerce issue. Downgraded to 4.3, no difference.
    Upgraded to 4.5 release candidate 1: bingo!
    filter
    Will await release of 4.5 on my live site.

    Had nothing to do with GP.
    Thanks for thinking along!

    #1423292
    Leo
    Staff
    Customer Support

    Glad I could help 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.