[Resolved] Featured Images Not Appearing in Twitter Feed

Home Forums Support [Resolved] Featured Images Not Appearing in Twitter Feed

Home Forums Support Featured Images Not Appearing in Twitter Feed

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1639771
    James

    Recently, I installed the Classic theme from the Site Library on my subdomain, miramichiflash.miramichireader.ca. I am having issues with my post’s featured images not appearing on my Miramichi Flash Twitter feed @FlashMiramichi. Two of the older posts do work correctly, but the three newer posts do not. There’s no problem with FaceBook, just Twitter. Am I missing something?

    James M. Fisher
    www.MiramichiReader.ca
    www.MiramichiFlash.ca

    #1639810
    Leo
    Staff
    Customer Support

    Hi there,

    The theme itself doesn’t control what social media displays when sharing your content.

    We would recommend using an SEO plugin like Yoast or RankMath as they have an option to add an image for each post/page that shows when you share it on social media.

    Hope this helps ๐Ÿ™‚

    #1639864
    James

    Thanks, Leo. Installing RankMath didn’t help. I’m not saying it is the theme because other posts display fine on Twitter. Just not all.

    James M. Fisher
    www.MiramichiReader.ca
    www.MiramichiFlash.ca

    #1640748
    Leo
    Staff
    Customer Support

    I’m not sure unfortunately.

    Did you assign a picture to each of the posts using RankMath?

    #1640835
    James

    Yes, but it didn’t help. There’s something about those three images that Twitter doesn’t like. I’m convinced of it. I appreciate your assistance.

    James M. Fisher
    www.MiramichiReader.ca
    www.MiramichiFlash.ca

    #1640849
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.