Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Featured images appearing twice

Home Forums Support Featured images appearing twice

  • This topic has 5 replies, 2 voices, and was last updated 5 years ago by Tom.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #153694
    Dave Walker

    Hi Tom,

    Thanks for the theme, which I’m enjoying using.

    I have one issue, which is that on every page and post the featured image is displayed a second time above the blog content. So what I’d like is a way to stop the featured image appearing as a header.

    I have ‘customise – blog – post image’ set to ‘hide’, but the images still all display twice.

    I do have a plugin that makes the first image in each post the featured image so that my thumbnails work when no featured image is set, but I wouldn’t have thought that this should affect this.

    Any help greatly appreciated.

    Dave

    #153779
    Tom
    Lead Developer
    Lead Developer

    Hi Dave,

    Is this only happening on single posts?

    If so, it’s possible that you’re adding the image to the content, and the featured image is showing as well.

    Try adding this CSS:

    .single .page-header-image-single {
        display: none;
    }
    #153949
    Dave Walker

    Thank you – that’s great for the single posts, which is the most important. Yes, it was just single posts and pages.

    Is there is a simple addition to the CSS that would do the same for pages? If not I can hide each header manually using the ‘Disable elements’ option, but if there is CSS it would be useful to know.

    Thanks,
    Dave

    #154003
    Tom
    Lead Developer
    Lead Developer

    For pages you can do this:

    .page .page-header-image {
        display: none;
    }
    #154347
    Dave Walker

    Thanks for help – much appreciated.

    #154415
    Tom
    Lead Developer
    Lead Developer
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.