[Resolved] Featured Image Dropping During Post Edits

Home Forums Support Featured Image Dropping During Post Edits

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1292397
    Brian

    Is anybody else seeing this problem?

    While editing posts, my featured images keep dropping out. It’s easy enough to re-establish them. The images are still present in the media library. It doesn’t happen every time I save a draft, but often enough to be pretty annoying. Once I publish the posts, the problem seems to go away.

    One of the volunteers on the WP support team seems to think it’s a theme-related issue. Any of y’all heard about it before?

    #1292405
    Leo
    Staff
    Customer Support

    Hi there,

    We haven’t had this issue reported.

    Are you referring to it dropping in the editor?

    That part is all handled by WP itself.

    It would be good to try disabling all plugins to see if any of them are causing the issue.

    If not test it with a twenty series WP theme.

    #1292414
    Brian

    Thanks for the quick response. Yes. It’s happening in the editor. I kinda figured all of that was handled in WP itself, but figured I’d cover all the bases. Thanks for the troubleshooting advice. I’ll try it out in my staging site with the 2020 theme. I know it’s pretty standard to suggest disabling all the plugins. Obviously, I can’t do that on the production site. I’ll let you know what I find out. Please let me know if you get wind of a similar issue from another user.

    Thanks,
    brian

    #1292420
    Leo
    Staff
    Customer Support

    Sounds. I’ll definitely keep an eye on this.

    An issue this obvious would definitely get reported pretty fast 🙂

    #1295802
    Brian

    This issue was being caused by a plugin I was using called EditorsKit. The plugin adds some rich text controls (e.g. subscript and superscript) to the <p> block context menu in the Gutenberg editor. I disabled that plugin and haven’t seen the featured image dropout again yet. Of course, that doesn’t mean I won’t see it again the next time I use the editor, but in the meantime, I think we can put this one to bed. Thanks for the help.

    #1295834
    Leo
    Staff
    Customer Support

    Thanks for reporting back!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.