[Resolved] featured image and post navigation don’t show with content template

Home Forums Support [Resolved] featured image and post navigation don’t show with content template

Home Forums Support featured image and post navigation don’t show with content template

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2050912
    Eva

    Hi!
    I have created a content template for my single posts, and that works just fine. I only have a problem displaying the featured image and the post navigation. I have set Display featured images and Display post navigation in the Customizer, but neither the features image nor the post navigation show in my single posts. I can’t find a solution, and hope you can!

    Thanks in advance,
    Eva

    #2050984
    David
    Staff
    Customer Support

    Hi there,

    the Content Template overwrites the Themes Content Template completely – that includes the hooks used to display things like featured images and post navigation.

    So for your Featured image, if above or below the post title within the content container – you need to include the Featured Image inside your Block Element Content Template using the GP Dynamic Image Block.

    For your Post Navigation, you would need to create a new Block Element for that … or include that within your Content Template.

    #2051191
    Eva

    Thank you David,

    I managed to include the featured image in the Block Content template. I assume I can only show it above or below the title?
    Now for the Post Navigation, I tried to include that in the content template too, but I can’t get it working… This is what I tried: https://prnt.sc/23a8tjw
    I am sorry, it must be easy, but I just can’t figure it out…
    Thanks again,
    Eva

    #2051296
    Ying
    Staff
    Customer Support

    Hi Eva,

    I assume I can only show it above or below the title?

    You can add it to any where in the content template, doesn’t have to be next to the title.

    For post navigation, try using this dynamic setting:
    Dynamic text type: Title.
    Dynamic link type: Previous/Next page of posts

    https://www.screencast.com/t/pEFaaf6l

    #2052202
    Eva

    Thank you Ying, it’s very clear and I did exactly what you suggested (https://prnt.sc/23fl8wj), but now there is no button but just the title of the actual post… I mostly use Firefox but I also opened the post in Edge and there is no button and no title. What to do now?!
    Thank you,
    Eva

    #2052301
    Ying
    Staff
    Customer Support

    Hum..seems a bug, we’ll look into it.

    Can you use headlineblock instead of the buttonsblock for this?

    Let me know ๐Ÿ™‚

    #2054389
    Eva

    I tried, but it doesn’t solve the problem…
    I have added a user account, hoping someone can look into this.
    Thank you!
    Eva

    #2054815
    Ying
    Staff
    Customer Support

    The username/password doesn’t work for me, can you check?
    https://www.screencast.com/t/TVgzxQ9171

    #2055027
    Eva

    I am sorry Ying.
    I have just changed the password, and tested it. It works for me.
    Thank you,
    Eva

    #2055095
    Ying
    Staff
    Customer Support

    Hi Eva,

    It should work now.

    The trick is to switch the element type to Post navigation when you are trying to add post navigation, then you should be able to see all the options:
    https://www.screencast.com/t/Ocx2BPgtp2Iy

    #2055360
    Eva

    Thank you Ying,

    I tried this, but the Source option doesn’t show, so the link directs to the actual post… I don’t understand what’s going wrong. Sorry for this. This is how it looks: http://prntscr.com/23ujct7

    Thank you.

    #2055967
    Ying
    Staff
    Customer Support

    It seems working fine: https://www.screencast.com/t/bCbzTcS1

    I also added an actual post navigation element for single post, you can publish it to see if that’s a better option.
    https://www.screencast.com/t/DlsEPkjFnJIc

    #2056104
    Eva

    Thank you so much, Ying. This works perfectly.
    Next time I will know how to do this. Very helpful and informative!
    Thank you again.
    Happy holidays and the best 2022!

    #2056107
    Ying
    Staff
    Customer Support

    You are welcome Eva ๐Ÿ™‚

    Wish you and your family merry Christmas and happy new year!

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.