[Resolved] Feature Posts Issue

Home Forums Support Feature Posts Issue

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1353784
    Christopher

    Hello this is an SEO question on the feature posts. I am seeing when I inspect just the Feature Post Title that it is an H2 should it not be an H1 for seo purposes? How do I fix this?

    #1353814
    David
    Staff
    Customer Support

    Hi there,

    the H1 is generally reserved for the title of a post. Which means all that pages content ( including subsequent H2’s etc. ) reside under that heading.

    When it comes to archives you want all Post Titles to have the same heading level so as they can be identified as individual articles and not just sub headings to your Featured Post.

    #1353846
    Christopher

    OK so you are saying that when Google crawls the featured posts they are not going to look for keywords in the title of just the featured post?

    Just so you know I am brand new at blogging I have built websites but I have never blogged before so this is all new to me

    #1354483
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I believe we resolved this in your other topic, but I’ll go ahead and post my answer in here as well just to complete/resolve the topic 🙂

    The post titles on the blog pages are h2 elements. This is because there should only be one h1 element per page. If all of those titles were h1 elements, it wouldn’t be good for SEO.

    If your blog page has a site title, it will be used as the h1 on the page.

    If not, you can add an h1 to the page using a Hook Element: https://docs.generatepress.com/article/hooks-element-overview/

    For example, you could:

    1. Add a Hook Element.
    2. Add this as the content:

    3. Set the hook to generate_before_main_content
    4. Set the Display Rules to your posts page (blog)

    Hope this helps!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.