[Resolved] Fatal Error when trying to open customizer

Home Forums Support [Resolved] Fatal Error when trying to open customizer

Home Forums Support Fatal Error when trying to open customizer

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #232277
    Jacks McNamara

    Hmmm. So I’ve been adding some products via woocommerce, and I also used regenerate thumbnails, and since doing these 2 things I now get this error message if I try to open the Customizer:

    Fatal error: Cannot redeclare generate_sanitize_typography() (previously declared in /home/jackuzxc/public_html/wp-content/plugins/gp-premium/typography/functions/functions.php:1825) in /home/jackuzxc/public_html/wp-content/themes/generatepress/inc/sanitize.php on line 27

    any idea what that could be? The site in question is http://jacksmcnamara.net. Everything has been working swimmingly until now.

    #232281
    Tom
    Lead Developer
    Lead Developer

    You’re using an old version of the theme.

    You can update it in “Appearance > Themes”.

    It’s important that whenever you update GP Premium or GP, you update the other if an update is available.

    That should fix it.

    Let me know ๐Ÿ™‚

    #232445
    Jacks McNamara

    whoops. feeling silly. Thank you, that did it.

    #232508
    Tom
    Lead Developer
    Lead Developer
    #237182
    Ryan

    I am experiencing a similar program but I am fairly sure that my theme and the premium plugin should be the correct versions together. They both apparently require updating but I want to do that very carefully as it is on a live website.

    Currently using theme version 1.3.34
    and using the premium plugin version 1.2.90

    Are these not compatible with each other in the customiser?
    Also have some customisations in the content.php file and I just need to know how this template may be affected.

    #237191
    Tom
    Lead Developer
    Lead Developer

    1.2.90 has an issue with older versions of the theme in the Customizer – I’ve made them compatible in 1.2.92 which I’m releasing tomorrow, but since GP and GP Premium work hand-in-hand, it’s very important that they’re always updated together.

    If you’ve customized content.php, use a child theme. Then you can just upload your content.php to the child theme and you can update the parent theme without worrying.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.