[Resolved] Fatal error: generate-page-header

Home Forums Support Fatal error: generate-page-header

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #133451
    smrcek

    Hey, Tom,
    thanks for GP, I like it, but now I have issue. I’ve made some actualizations (WP 4.2.4 -> 4.3) and some (not GP) plugins and now Im getting this error (at frontend, admin part is OK): Fatal error: Cannot redeclare cmb2_dir() in …/bufur.cz/wp-content/plugins/gp-premium/addons/generate-page-header/inc/cmb2/includes/helper-functions.php on line 9.

    Any suggestions, how to fix it, please? In wp-content/plugins I have no directiories with standalone version of generate page header addon, I think. Just gp-premium/addons/generate-page-header directory.

    #133469
    smrcek

    OK, I’ve found, that problem has something to do with Maps Builder (MB) plugin made by WordImpress, which I upgraded to the latest 2.0 version today (and from that moment fatal error appeared).
    I’m inserting custom map into “After Footer Widgets” using shortcode generated by MB. If I deactivate MB plugin, site works well, but I have no maps. If I deactivate GP Page Header addon, I have map, but layout of website is broken, because I have no custom headers in pages and posts.
    I really don’t know, if this is MB plugin issue or if it can be fixed in GP, because I’m not programmer.
    Strange thing is, that I have almost exact copy of this site on my development hosting. I’ve tried that actualizations (MB & WP & GP) before I did them on live site. Issue appeared too, but after a few clicks/refreshes site started work again with both things activated. Difference between my development site and live site is, that on my development site i have no cache plugin installed and permanent links are turned off, but I’ve tried to turn off both on my live site and issue is still here.
    Sorry for my english, I hope you will have some advice or you will find some solution. Thanks

    #133509
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    What version of Page Header/GP Premium are you using?

    This used to be an issue a while ago, but we added a check to make sure there wasn’t any conflict with other plugins.

    Let me know 🙂

    #133513
    smrcek

    Hi, Tom, version of GP Premium plugin: 1.2.64, version of GeneratePress: 1.3.11 – both latest, I think, no actualization notifications.

    #133515
    Tom
    Lead Developer
    Lead Developer

    Ah, this was fixed in 1.2.65 (we’re currently on 1.2.69).

    If you update to the latest version this shouldn’t an issue 🙂

    #133524
    smrcek

    Ah, you are right, now I see, that on my test site plugin version is 1.2.69 and thats why there is no problem. But on live site the plugin version is 1.2.64 and I have no notification in dashboard, that I can update to version of plugin. That’s weird. Is there any way how to force WP to check if there is a newer version of plugin?

    #133529
    smrcek

    Ok, I tried deactivate and reactivate updates in settings and notification about update to 1.2.69 came here. 🙂 Now everything works again, thanks a lot for your time and your theme/plugin, Tom! 🙂

    #133592
    Tom
    Lead Developer
    Lead Developer

    Awesome, glad you got it all sorted! 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.