[Resolved] Facebook posts not displaying post’s featured image

Home Forums Support [Resolved] Facebook posts not displaying post’s featured image

Home Forums Support Facebook posts not displaying post’s featured image

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1545798
    James

    I’m not sure where this issue lies,but when I post a link to one of my site’s posts on Facebook, its featured image does not show. Instead, it pulls one of images from my sidebar ads. This started happening only recently, and I cannot figure out what might be causing it.
    My site is: http://www.MiramichiReader.ca

    Thanks,

    James M. Fisher
    www.MiramichiReader.ca
    www.MiramichiFlash.ca

    #1546193
    David
    Staff
    Customer Support

    Hi there,

    Currently your posts are using the Header Element to display the featured image. This is loaded via CSS so Facebook won’t see an tag for it to use.

    if you’re not using an SEO plugin, which generally provides the option to set the shared image, you may want to try this plugin:

    https://en-gb.wordpress.org/plugins/og/

    It will add the OG meta data including the featured image URL for Facebook to use.

    #1546492
    James

    Thanks David for pointing me in this direction. I will try this later today and report back.

    James M. Fisher
    www.MiramichiReader.ca
    www.MiramichiFlash.ca

    #1546495
    David
    Staff
    Customer Support
    #1546519
    James

    Perfect! Works as advertised.

    James M. Fisher
    www.MiramichiReader.ca
    www.MiramichiFlash.ca

    #1546622
    David
    Staff
    Customer Support

    Awesome – thanks for letting us know.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.