[Resolved] error 500 when i try to add the classic theme. Host gator says it is the menu ic

Home Forums Support [Resolved] error 500 when i try to add the classic theme. Host gator says it is the menu ic

Home Forums Support error 500 when i try to add the classic theme. Host gator says it is the menu ic

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1113482
    Mike

    i am trying to add eh GP classic theme and when i do, i get a error #500 that is related to teh menu icon plugin and my site crashes. Please help.

    error is below:
    Warning: Invalid argument supplied for foreach() in /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php on line 69

    Fatal error: Uncaught TypeError: Argument 1 passed to kucrut_get_array_value_deep() must be of the type array, string given, called in /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php on line 192 and defined in /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/library/functions.php:19 Stack trace: #0 /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php(192): kucrut_get_array_value_deep(”, Array) #1 /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php(173): Menu_Icons_Settings::get(‘menu_22’) #2 /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php(133): Menu_Icons_Settings::get_menu_settings(22) #3 /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php(99): Menu_Icons_Settings::is_menu_icons_disabled_for_menu() #4 /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/menu-icons.php(146): Menu_Icons in /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/library/functions.php on line 19

    #1113492
    Mike

    i cant back in the plug in section of my WP site. This is the message i am getting:
    Warning: Invalid argument supplied for foreach() in /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php on line 69

    Warning: Cannot modify header information – headers already sent by (output started at /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php:69) in /home4/adad43boys/diyweddingworks.com/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home4/adad43boys/diyweddingworks.com/wp-content/plugins/menu-icons/includes/settings.php:69) in /home4/adad43boys/diyweddingworks.com/wp-includes/pluggable.php on line 1268

    #1113538
    Mike

    sorry for my spelling errors. if i use the generic GP website all is ok. When i try and update to the Classic library site is when i get this message. Host Gator says it is something to do with the menu icon plug in. I have disabled it and deleted it but it still crashes my site when i try and add the classic site..

    #1113554
    Tom
    Lead Developer
    Lead Developer

    That’s strange – there must be an error with that plugin at the moment. Once you install Classic and disable the plugin, are you able to continue with your site?

    We’ll investigate and replace the plugin in the site if needed.

    #1113560
    Mike

    Hi Tom
    Sorry to bother you on Christmas eve! The install of the classic stalls in the middle and gives me the 500 error. I then have to call Host Gator to get me back into my site as it kicks me out.Thye disabled it and then after a few attempts i deleted all my plugins and started from scratch with a clean slate and it did it again. so for now i am in a holding pattern..

    #1113992
    Tom
    Lead Developer
    Lead Developer

    That’s strange – I’m not seeing any similar reports in their support forum.

    If Host Gator can disable the plugin, you should be able to continue building your site (including the Classic site).

    Is Classic not still installed once Menu Icons is disabled?

    #1114557
    Mike

    Hostgator has to disable it as it is the problem. I cant load the Classic theme at all. I just loaded the Article theme and it imported fine. The menu icon plugin is the problem. Hostgator thought my php may have been the problem so they upgraded it and tested it and said it is the menu icon. i tried to get help on the menu icon site but could not figure that one out. SO any help you can give me would be appreciated as i really want to use the Classic. Thank you

    #1114584
    Tom
    Lead Developer
    Lead Developer

    So Classic doesn’t fully import? If you import Classic and the import works, then you should be able to disable Menu Icons and still use the site using Classic.

    Menu Icons is used on 200,000+ websites, and I’m not seeing any reports of errors in their forums: https://wordpress.org/support/plugin/menu-icons/

    I just did a test import of Classic using WP 5.3.2 and PHP 7.2.0 – didn’t encounter any errors.

    Can you confirm you’re using the latest WP version?

    #1114595
    Mike

    ok so it finally worked. Not sure what the problem was. I reinstalled WP and maybe that did the the trick?
    Thanks for you help Tom!

    #1114597
    Tom
    Lead Developer
    Lead Developer
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.