[Resolved] "Ensure text remains visible during webfont load"

Home Forums Support "Ensure text remains visible during webfont load"

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1166820
    Michael

    Hi guys,

    I am running through the tests in https://web.dev/measure/. I applied their recommendation for webfont load by adding font-display:swap to the @font-face declarations for local fonts in my css, and that seems to have taken care of the fonts from my side, but there appear to be a couple of generate press fonts remaining listed in the new test results. Not a big deal, but I just thought it might be helpful for me to let you know. I realize one of the fonts is icon based so does not apply, but am not sure about the other:

    /wp-content/themes/generatepress/fonts/generatepress.woff2

    #1166861
    David
    Staff
    Customer Support

    Hi there,

    that font is the GeneratePress icons font – in Customizer > General > Icon Type – switch to SVG.

    #1166868
    Michael

    Hi David,

    Thanks a lot for getting back to me. Just to clarify – is there anything else I would need to do if I switch that to SVG (so as not to break anything)?

    #1166874
    David
    Staff
    Customer Support

    As long as you’re not using the GeneratePress icons as a font anywhere in your own custom code then nope.

    #1166922
    Michael

    I’m only using IcoMoon and Google Fonts as local fonts as far as I know – so will give that a go then.

    Thank you David 🙂

    #1166925
    Michael

    That seems to have done the trick. The site is still in one piece 😉

    Thanks again!

    #1166939
    David
    Staff
    Customer Support

    Glad to hear that 🙂

    #1448845
    A. R. Choudhury

    Hi David, I followed your guide. But whenever I select SVG, my menu looks like this: http://prntscr.com/ujm2vz

    #1448854
    David
    Staff
    Customer Support

    Hi there,

    try clearing any plugin and server caches.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.