[Resolved] Embedded Form Not Working As Expected Within Element Hook

Home Forums Support [Resolved] Embedded Form Not Working As Expected Within Element Hook

Home Forums Support Embedded Form Not Working As Expected Within Element Hook

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #2248067


    I have embedded Mailerlite email sign up forms on my site, and I use the form html to add to the site.

    The form code is in a widget in the footer and at the base of each page, and it works as expected, which is when the name and email is entered and you click subscribe a success message is displayed in the same place as the form was.

    For posts I have the html code in a hook in Elements to display at the end of the post (see link provided for example).

    However, the form within the hook is not working correctly. On entering the information and clicking the subscribe button, the success message is not displayed (as it is in the other locations). It looks as is the form hasn’t worked.

    The data IS transferred to my email provider, so the form is collecting and sending the data, but the success message is not displayed.

    Can you please advise if this is an issue with how I have the hook set up or is it more likely an issue with the form html?


    Customer Support

    Hi there,

    on the single post neither the below content Form or footer form takes me to the ‘success’ page where it asks me to check my email.
    I wonder if its to do with their being two forms on that page?

    If you use the Disable Elements meta box in the post editor to temporarily remove the footer widgets on just that post, so there is no footer form. Does you below content form now behave correctly?


    Hi David,

    When I try any of the forms in the same browser as where I am logged in to the site, the forms work and the success message is displayed.

    However in an incognito window in a separate session, none of the forms work like you said, even with the footer removed.

    I can’t remember which URL I gave you – so see the notes for the one I have removed the footer from.

    It doesn’t seem to have solved the issue, but perhaps it isn’t an elements issue.


    Customer Support

    Hi Rachel,

    I tried both forms on incognito mode, and here are the results.

    The first form leads me to a new link but no success message: https://share.getcloudapp.com/geuRWJKR

    The second one doesn’t show anything: https://share.getcloudapp.com/8Lu0jxWd

    I got an email from both forms though.

    Can you try clearing your cache? If that doesn’t work, can you try temporarily disabling all caching/optimization mechanisms you have set in your website?

    Kindly let us know how it goes.


    Hi Fernando,

    The first form is fine – there are no issues with that one. It is the second one you tested (pink image) that doesn’t show a success message that is the issue. If you look at the html for the form it should show you a message in place of the form to say your email has been submitted..

    So that is the issue I am trying to resolve. I will take a look without caching and let you know.


    Customer Support

    I see. Thank you for clarifying.

    Looking forward to your update.


    When I test the form using ?nocache on the end of the URL the form at the base of the post works as expected – the “Nearly there” success message is displayed in place of the form.

    I don’t know what this means though and how to resolve!

    Customer Support

    Hi Rachel,

    Tested as well and it seems to be working with ?nocache on my end as well: https://share.getcloudapp.com/geuRzNQj

    To confirm, I also test without it, and indeed, viewing a cached version of the site has the issue: https://share.getcloudapp.com/P8uQb4P1

    I also tested on incognito with no Browser cache, and the issue also existed there: https://share.getcloudapp.com/OAu8qDXk

    Adding ?nocache allows to view the uncached version of the site.

    Noticed you’re using WP rocket as well so I tested adding ?nowprocket and it worked: https://share.getcloudapp.com/8Lu0PO8D

    With that said, it seems that WP rocket is causing the issue. Its caching or one of its optimization settings may be causing this. Perhaps WP rocket has an insight with regards to this, and which specific setting is causing this.

    One setting I’m thinking could cause this is Minification of CSS or JS, or deferring of JS. You could probably test this and see how it goes.

    Hope this clarifies!


    Ok thank you – I will submit a support request with WP Rocket. Thanks for your help.

    Customer Support

    You’re welcome Rachel!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.