[Support request] Eliminate render-blocking resources

Home Forums Support [Support request] Eliminate render-blocking resources

Home Forums Support Eliminate render-blocking resources

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1527272
    24xstudio

    Hey,

    I am using WPRocket with a one-click Critical CSS option enabled. The problem I am facing is that whenever I disable it I get bad pagespeed scores.

    So after enabling the Critical CSS I have excluded two above the fold CSS files from Optimize CSS Delivery as they were causing CLS issues and all the other scores are good.

    So now I am facing bad First Contentful Paint and Largest Contentful Paint.

    How can I improve them without making the CLS score poor?

    #1527325
    Leo
    Staff
    Customer Support

    Hi there,

    I just view the link you’ve provided the CLS is at 0.003 which is really small and I would say that can be ignored. Can’t see any differences in the screenshot either:
    https://www.screencast.com/t/2bhvDehjTU

    You might need to check with WP Rocket’s support team and see if they have any recommendations on how to tweak the settings.

    #1527361
    24xstudio

    Hey,

    How can I improve these: https://prnt.sc/vhm9lb

    Using critical CSS is a headache and it doesn’t give perfect results.

    #1527484
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The main thing you can do to help your speed is to use a plugin like Autoptimize to combine your render-blocking resources. It will take all of those resources and put them into one or two files.

    Other than that, you’ll want to reduce the size of your content as much as possible. Optimize your images, try to remove Font Awesome etc..

    #1527692
    24xstudio

    Hey,

    I am already using WPRocket to minify the CSS, also I am not combining the CSS and JS files in WPRocket as they are being served via HTTP/2.

    Plus I have already shifted from fontawesome yo SVG icons. I am now left with one plugin which is using fontawesome by default and I cannot change it ๐Ÿ™

    Talking about the images, I am using webp format with BunnyCDN.

    Lastly, I tried Autoptimize and configured it as you recommended in the docs, it’s also not solving the issue.

    After your suggestion, I installed autoptimize again for CSS and JS optimization, and here are my setting: https://ibb.co/LN8gvxc

    P.S: I am also using WPRocket for caching other things.

    Can I give access so that you can check and provide some solutions?

    Keep up the awesome work ๐Ÿ™‚

    #1528647
    Leo
    Staff
    Customer Support

    Tom has basically provided the best suggestion we can do here unfortunately.

    I’m not sure if there are any actual solutions to your problems.

    You could try to check with WP Rocket’s support to see if they can provide anymore optimization suggestions.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.