[Support request] Elementor Template Section has content instead of being blank.

Home Forums Support Elementor Template Section has content instead of being blank.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1221063
    David

    In the Elementor custom templates, I get a template preloaded by GeneratePress instead of having a blank canvas. This does not happen with the Astra theme that I use. Please let me know how to remedy this situation. I can not build on an already filled canvas.

    Elementor Template Section has content instead of being blank.

    A picture has been attached.

    https://snipboard.io/9ZUnfO.jpg

    #1221344
    Leo
    Staff
    Customer Support

    Hi there,

    Not sure if I understand.

    The page you’ve linked is basically 100% coming from Elementor including the header footer etc.

    Nothing is really coming from GP.

    GP definitely doesn’t pre-load any Elementor templates for you when you activated the plugin.

    #1709108
    Fernando

    Hi Leo

    Having the same problem. (using GP pro Version, all Addons OFF)
    I’m going to try to explain:

    When you start a neu Template in Elementor Theme Builder u can:

    Make a New Page
    With this choice you can Start Designing yr own Pages (Header/Footer/Single/Post/404/etc). Here you can decide how you want to work: Default/Blank Canvas or Fullwidth. Here you will receive a Blank page with all Padding/Margins coming from Elementor. Perfect.

    Now, if a want to make a new SECTION and open it with Elementor, you see a Page with Sidebars/Widgets, you cannot decide if you want Blank Canvas or Fullwidth… and the Spacing is not consinstent with my Elementor Setup.

    Screenshots

    I cannot figure out where is this Information coming from…

    #1709110
    David
    Staff
    Customer Support

    Hi there,

    that is an issue you should raise with Elementor…. however you can try the following:

    1. Enable the Elements Module in Appearance > GeneratePress
    2. Create a new Layout Element:

    https://docs.generatepress.com/article/layout-element-overview/

    2.1 Set the Content Container to Full Width, and Disable the Sidebars etc.
    2.2 Set the Display Rules to Template > All Templates.

    #1709252
    Fernando

    Hi David

    That worked perfectly…. Thank you!

    Somehow Elementor oversee my setup when the default/Theme is used and pick the Generatepress standard. With your changes it works… important to know maybe: i made a mistake declaring the width at the Content container… This field should stay empty.

    #1709565
    David
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.