[Resolved] Elementor social icons not working anymore with GP

Home Forums Support [Resolved] Elementor social icons not working anymore with GP

Home Forums Support Elementor social icons not working anymore with GP

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #574287
    Tom

    I understand support for fontAwesome was removed. I added the FA library following the steps mentioned here: https://docs.generatepress.com/article/font-awesome/#font-awesome-5. With this I could add icons to menu items.

    I also don’t see the “load essential icons” checkbox in General>Settings – but I have read somewhere that if you check that once and then save, you will not see it again (sorry if this is not very precise). SO I’m guessing I cannot have any access anymore to that setting, correct?

    Anyway, then I tried to use the Social Icons widget in Elementor but that also stopped working. When I inspect the page I see Elementor is still trying to use old FA icons like this: <i class=”fa fa-facebook”></i>.

    So how can I get the Social Icons widget in Elementor to work now?

    GeneratePress 2.1.1
    GP Premium 1.6.2
    #574372
    David
    Staff
    Customer Support

    Hi Tom,
    Yes essential FA icons were removed as GP now uses its own icon set.
    By adding FA5 it actually breaks the FA4 library that Elementor uses. So to work with Elementor, you want to remove the FA5 code you have added.

    #574407
    Tom

    Great to know. Thanks David.

    Can these GP icons be used in a similar was as the FA icons? Is there any doc available about how to use the GP set of icons?

    #574897
    David
    Staff
    Customer Support

    Hi Tom,

    The icons in GP aren’t meant for general use within your content – they’re theme icons for built in elements (menu bars, close icons, search etc..). They literally replaced the handful of FA essential icons that were being used before.

    David

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.